aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlessandro Portale <alessandro.portale@qt.io>2020-02-07 11:54:19 +0100
committerAlessandro Portale <alessandro.portale@qt.io>2020-02-10 12:09:18 +0000
commit1a0af1ca226e55d353239b016d1ef1d4d1f70069 (patch)
tree2822e888f421c4f68120dd2eb8842022acc403f6 /CMakeLists.txt
parent6627cb2f3faa3b4dcec66e894c67d3fd2194c7c8 (diff)
CMake Build: Let the version dialog log link point to the repo of origin
https://github.com/<qtcreator-fork>/commits/<sha> Instead of expecting a "%1" placeholder in the passed-in IDE_REVISION_URL_STR, we now expect IDE_REVISION_URL_STR to be a plain URL. Reason is that passing a string containing "%1" from CMake to the VersionDialog caused a premature replacement of that placeholder somewhere on the way. Also log the CMake configure call in build_cmake.yml Change-Id: I4c1a946c66f891101576e3556ca87a004cead950 Reviewed-by: Eike Ziller <eike.ziller@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c4077ac3e9..cb79a450f0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,8 +8,9 @@ include(QtCreatorIDEBranding)
set(IDE_REVISION FALSE CACHE BOOL "Marks the presence of IDE revision string.")
set(IDE_REVISION_STR "" CACHE STRING "The IDE revision string.")
+set(IDE_REVISION_URL_STR "" CACHE STRING "The IDE revision Url string.")
-mark_as_advanced(IDE_REVISION IDE_REVISION_STR)
+mark_as_advanced(IDE_REVISION IDE_REVISION_STR IDE_REVISION_URL_STR)
project(QtCreator VERSION ${IDE_VERSION})