aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEike Ziller <eike.ziller@qt.io>2020-06-04 09:45:23 +0200
committerEike Ziller <eike.ziller@qt.io>2020-06-04 14:07:54 +0000
commit3d80fb587297e7ff29687e5c5b3c8b30a58d2957 (patch)
treeb2948e3e3868b13b8b0fb0f539c7ca504a8b983d /CMakeLists.txt
parentb0e5a30f62a853c39933c01364d63f2a793927e8 (diff)
CMake build: Add feature info for building tests
Was wondering if my current build included tests or not... Change-Id: I17030455ffd89d6b482e8cc08da3cb3b2dcbbe35 Reviewed-by: Cristian Adam <cristian.adam@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ee0e0051d3..f76ce0a151 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -22,6 +22,7 @@ set(CMAKE_CXX_STANDARD_REQUIRED ON)
set(CMAKE_CXX_EXTENSIONS OFF)
option(WITH_TESTS "Build Tests" OFF)
+add_feature_info("Build tests" ${WITH_TESTS} "")
option(WITH_DEBUG_CMAKE "Enabled CMake project debugging functionality (e.g. source file disk checking)" OFF)
option(BUILD_WITH_PCH "Build with precompiled headers" ON)