aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCristian Adam <cristian.adam@qt.io>2020-05-26 12:02:33 +0200
committerCristian Adam <cristian.adam@qt.io>2020-05-26 11:41:44 +0000
commita81b6b623e8ac6da811b5de35ff4114b2bfada59 (patch)
tree78cd8e051fb97f696e7a536a7b57e05de2d7c04c /CMakeLists.txt
parent0aa1a3ad4ba5899929d84c12977adc5e188cb4ee (diff)
CMake Build: Update CMake minimum Version to 3.10
This is due to policy CMP0071 which affects AUTOMOC and generated files. With CMP0071 set to OLD (CMake 3.9) precompiled headers would fail to work with GCC. GCC and precompiled headers would still require the upcoming 3.18 CMake, but having CMP0071 set to NEW (CMake 3.10) is a prerequisite. Change-Id: I7c3c1f739877646a91ffa07e2a8006ab7d6f4d77 Reviewed-by: Eike Ziller <eike.ziller@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 062a321872..e355b1d0f2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,4 +1,4 @@
-cmake_minimum_required(VERSION 3.9)
+cmake_minimum_required(VERSION 3.10)
## Add paths to check for cmake modules:
list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake")