aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEike Ziller <eike.ziller@qt.io>2020-05-19 09:42:44 +0200
committerEike Ziller <eike.ziller@qt.io>2020-05-25 11:31:06 +0000
commitb3ffd8d1ebe2cfd3f84bfd3d9e926e1a291ffbf6 (patch)
tree130ec7c816b88b510ea7bacfbf9ecce6a9dba8b4 /CMakeLists.txt
parent52188918c0d4c90c38be99eb2c4586dd3a11b67f (diff)
CMake build: Move documentation functions to re-usable location
Removes "install_..._docs" and "clean_docs" special targets. Instead install documentation with "--install . --component qch_docs" and "--install . --component html_docs" which have the advantage that the install prefix can be specified later on with --prefix. Also removes export of IDE_SOURCE_DIR, which is not used. Change-Id: I4fce0b9aa8c7fc40b7e94e065777ddf4c0b76c41 Reviewed-by: Cristian Adam <cristian.adam@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt35
1 files changed, 1 insertions, 34 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 926cd34165..062a321872 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -6,6 +6,7 @@ list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake")
include(FeatureSummary)
include(QtCreatorIDEBranding)
include(QtCreatorTranslations)
+include(QtCreatorDocumentation)
set(IDE_REVISION FALSE CACHE BOOL "Marks the presence of IDE revision string.")
set(IDE_REVISION_STR "" CACHE STRING "The IDE revision string.")
@@ -46,40 +47,6 @@ find_package(Qt5 COMPONENTS LinguistTools)
find_package(Threads)
-# Get information on directories from qmake
-# as this is not yet exported by cmake.
-function(qt5_query_qmake)
- if (NOT TARGET Qt5::qmake)
- message(FATAL_ERROR "Qmake was not found.")
- endif()
-
- get_target_property(_qmake_binary Qt5::qmake IMPORTED_LOCATION)
- execute_process(COMMAND "${_qmake_binary}" "-query"
- TIMEOUT 10
- RESULT_VARIABLE _qmake_result
- OUTPUT_VARIABLE _qmake_stdout
- OUTPUT_STRIP_TRAILING_WHITESPACE)
-
- if (NOT "${_qmake_result}" STREQUAL "0")
- message(FATAL_ERROR "Qmake did not execute successfully: ${_qmake_result}.")
- endif()
-
- # split into lines:
- string(REPLACE "\n" ";" _lines "${_qmake_stdout}")
-
- foreach(_line ${_lines})
- # split line into key/value pairs
- string(REPLACE ":" ";" _parts "${_line}")
- list(GET _parts 0 _key)
- list(REMOVE_AT _parts 0)
- string(REPLACE ";" ":" _value "${_parts}")
-
- set("${_key}" "${_value}" CACHE PATH "qmake import of ${_key}" FORCE)
- endforeach()
-endfunction()
-
-qt5_query_qmake()
-
find_package(Qt5 COMPONENTS Designer Help Script SerialPort Svg QUIET)
function (set_if_target var target)
if (TARGET "${target}")