aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTobias Hunger <tobias.hunger@qt.io>2019-05-23 15:13:06 +0200
committerTobias Hunger <tobias.hunger@qt.io>2019-09-17 12:37:14 +0000
commitc3f31b6332e4b96e2089b0d6a15d617cc2cae49f (patch)
tree833bd21bd86cc260eefadd5fb1e305413140dff2 /CMakeLists.txt
parentdac42e9e28be1d9dade5acedee82271fba794495 (diff)
CMake: Handle translations
(Optionally) re-generate .ts files from CMake by running lupdate and run lrelease to generate .qm files. Changes to qmake: * src/libs/3rdparty/syntax-highlighting/src/cli/kate-syntax-highlighter.cpp is no longer translated: It's a command line tool that is not used by creator * src/libs/aggregation/examples/text/main.cpp is no longer included in ts files * src/libs/qt-breakpad/qtcrashhandler/* is no longer included in ts files: It is not built right now Change-Id: Iec018da86a111a68ec983a880cef2961b48ccdf9 Reviewed-by: Cristian Adam <cristian.adam@qt.io> Reviewed-by: Eike Ziller <eike.ziller@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 41278e8d93..c047ca59d5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -35,8 +35,8 @@ if (WITH_TESTS)
endif()
find_package(Qt5
- COMPONENTS Concurrent Core Network PrintSupport Qml Quick QuickWidgets
- Sql Widgets ${_TEST_QT_COMPONENT}
+ COMPONENTS Concurrent Core LinguistTools Network PrintSupport Qml Quick
+ QuickWidgets Sql Widgets ${_TEST_QT_COMPONENT}
REQUIRED
)