aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorEike Ziller <eike.ziller@qt.io>2021-10-20 11:38:26 +0200
committerEike Ziller <eike.ziller@qt.io>2021-10-20 12:07:39 +0000
commitae0b648a853d5e4687f2f9d71c902856dcb3d42b (patch)
tree4cf18787335c63526ccbc0f37ad46c4427e06405 /src/CMakeLists.txt
parent181a2927fe256dc73fa383b716697485d913c3b2 (diff)
CMake build: Allow compilation without QtQuick
Disable the parts that require it in that case. Change-Id: I3f62eb9b325905ea225009aad6b9020cef545da6 Reviewed-by: Cristian Adam <cristian.adam@qt.io>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 799d8ef68c..70dfa9b5f6 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -51,8 +51,9 @@ endif()
include(CMakeFindDependencyMacro)
find_dependency(Qt5 ${IDE_QT_VERSION_MIN}
- COMPONENTS Concurrent Core Gui Widgets Core5Compat Network PrintSupport Qml Quick QuickWidgets Sql REQUIRED
+ COMPONENTS Concurrent Core Gui Widgets Core5Compat Network PrintSupport Qml Sql REQUIRED
)
+find_dependency(Qt5 COMPONENTS Quick QuickWidgets QUIET)
if (NOT IDE_VERSION)
include(\${CMAKE_CURRENT_LIST_DIR}/QtCreatorIDEBranding.cmake)