aboutsummaryrefslogtreecommitdiffstats
path: root/src/app/CMakeLists.txt
diff options
context:
space:
mode:
authorEike Ziller <eike.ziller@qt.io>2022-02-04 14:07:34 +0100
committerEike Ziller <eike.ziller@qt.io>2022-02-16 07:50:48 +0000
commit041e8d178fd88136e2d72e043ce431e2fd3e73ad (patch)
tree8f6cbeb3fe6b05a03484a56138a48e8bdee5391a /src/app/CMakeLists.txt
parentaef1954bcf1739a5799907b91f8530f68da4115e (diff)
Linux: (Optionally) Enforce XCB backend if QT_QPA_PLATFORM is not set
Especially on older distributions, Qt/Wayland works worse than Qt/ XCB(XWayland). On Ubuntu 20.04, starting Qt Creator with Wayland can even crash the Wayland session (https://bugs.launchpad.net/ubuntu/+source/mutter/+bug/1958684/). We still want to ship the plugins, and allow forcing the usage of Wayland, since on the other hand Wayland works better in HiDPI environments for newer distributions. Behavior is enabled when configuring with -DQTC_FORCE_XCB=ON Task-number: QTCREATORBUG-26867 Change-Id: I623f001412f809381208b6cb3ec5b3fcfdb86011 Reviewed-by: <github-actions-qt-creator@cristianadam.eu> Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: hjk <hjk@qt.io> Reviewed-by: Robert Löhning <robert.loehning@qt.io>
Diffstat (limited to 'src/app/CMakeLists.txt')
-rw-r--r--src/app/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/app/CMakeLists.txt b/src/app/CMakeLists.txt
index ad9ef52f49..b77138468e 100644
--- a/src/app/CMakeLists.txt
+++ b/src/app/CMakeLists.txt
@@ -92,6 +92,13 @@ if (APPLE)
)
endif()
+option(QTC_FORCE_XCB "Enables that Qt Creator forces XCB on Linux if QT_QPA_PLATFORM is not set." OFF)
+extend_qtc_executable(qtcreator
+ CONDITION QTC_FORCE_XCB
+ DEFINES
+ QTC_FORCE_XCB
+)
+
extend_qtc_executable(qtcreator
CONDITION BUILD_WITH_CRASHPAD
DEFINES