aboutsummaryrefslogtreecommitdiffstats
path: root/src/app/CMakeLists.txt
diff options
context:
space:
mode:
authorEike Ziller <eike.ziller@qt.io>2023-01-23 11:44:31 +0100
committerEike Ziller <eike.ziller@qt.io>2023-01-24 15:35:46 +0000
commit06c4df37b9052b591a05d04ffc93ebf6f7edae17 (patch)
tree6073fcb62ba1e3cf58b3ba9cd180ca690f59923b /src/app/CMakeLists.txt
parentf37aa909ac56d84bde92a5ee6650d578cd871196 (diff)
CMake build: Remove usages of Qt5_VERSION
and remove checks for Qt < 6.2, since that is our minimum version. Except for sdktool and qml2puppet. Change-Id: Id36cd1a15a5a6e5480e4ae5d0a8ffaea4b2a1864 Reviewed-by: Cristian Adam <cristian.adam@qt.io> Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: <github-actions-qt-creator@cristianadam.eu>
Diffstat (limited to 'src/app/CMakeLists.txt')
-rw-r--r--src/app/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/app/CMakeLists.txt b/src/app/CMakeLists.txt
index a7090e2d95..940ae30a59 100644
--- a/src/app/CMakeLists.txt
+++ b/src/app/CMakeLists.txt
@@ -66,7 +66,7 @@ if (QTC_STATIC_BUILD)
SOURCES "${CMAKE_CURRENT_BINARY_DIR}/plugin_imports.cpp"
)
- if (Qt5_VERSION VERSION_GREATER_EQUAL 6.0.0 AND TARGET QmlDesigner)
+ if (TARGET QmlDesigner)
qt6_import_qml_plugins(qtcreator
PATH_TO_SCAN "${CMAKE_CURRENT_SOURCE_DIR}/../../share/qtcreator/qmldesigner")
endif()