aboutsummaryrefslogtreecommitdiffstats
path: root/src/app/CMakeLists.txt
diff options
context:
space:
mode:
authorEike Ziller <eike.ziller@qt.io>2022-02-15 11:26:23 +0100
committerEike Ziller <eike.ziller@qt.io>2022-02-15 13:59:36 +0000
commit45c018f560ac6c75ea43c356afc9a68b1db403db (patch)
tree3e300028032b2743f4366f82dfbedd326e4a85a8 /src/app/CMakeLists.txt
parentdad534005ea33d4484ec9e92b48b3ce5588c5e01 (diff)
macOS: Disable ApplePressAndHold
That feature allows entering special characters by holding a key, e.g. holding the 'l' key opens a popup that allows entering 'ł'. Since that disables key repeat, we don't want it, though. Fixes: QTCREATORBUG-26925 Change-Id: I5638337447778b0c873c68195307b92133882e69 Reviewed-by: <github-actions-qt-creator@cristianadam.eu> Reviewed-by: Tor Arne Vestbø <tor.arne.vestbo@qt.io>
Diffstat (limited to 'src/app/CMakeLists.txt')
-rw-r--r--src/app/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/app/CMakeLists.txt b/src/app/CMakeLists.txt
index ed41f3dce0..ad9ef52f49 100644
--- a/src/app/CMakeLists.txt
+++ b/src/app/CMakeLists.txt
@@ -24,6 +24,12 @@ add_qtc_executable(qtcreator
QTC_RUNNABLE
)
+extend_qtc_executable(qtcreator
+ CONDITION APPLE
+ SOURCES
+ main_mac.mm
+)
+
if (NOT TARGET qtcreator)
return()
endif()