aboutsummaryrefslogtreecommitdiffstats
path: root/src/app/CMakeLists.txt
diff options
context:
space:
mode:
authorEike Ziller <eike.ziller@qt.io>2020-11-12 16:10:30 +0100
committerEike Ziller <eike.ziller@qt.io>2020-11-13 11:04:32 +0000
commit98db9774f2363314f51b1732646396112418320e (patch)
treed43cff865d24e347c4d9ea43fb5283c131d415e6 /src/app/CMakeLists.txt
parent11ce7e120600dc4b11cb3843d10d1cf4b1762ba5 (diff)
cmake build: Do not copy whole app bundle directory when installing
CMake just copies the whole app bundle directory when installing a target, but we copy various things there that should not be part of the installation, like static libraries, executables with SKIP_INSTALL, Clang resources, and potentially .dSYM bundles. Fixes: QTCREATORBUG-24021 Change-Id: I98bb466b664d2d6d203f3adc20d8345d9b3ce3cc Reviewed-by: Cristian Adam <cristian.adam@qt.io>
Diffstat (limited to 'src/app/CMakeLists.txt')
-rw-r--r--src/app/CMakeLists.txt16
1 files changed, 11 insertions, 5 deletions
diff --git a/src/app/CMakeLists.txt b/src/app/CMakeLists.txt
index ce469f86aa..0e52bde5dd 100644
--- a/src/app/CMakeLists.txt
+++ b/src/app/CMakeLists.txt
@@ -66,10 +66,16 @@ if (APPLE)
"${CMAKE_CURRENT_BINARY_DIR}/qtcreator.icns"
"${CMAKE_CURRENT_BINARY_DIR}/qtcreator-project.icns"
)
- set_source_files_properties(
- "${CMAKE_CURRENT_BINARY_DIR}/qtcreator.icns"
- "${CMAKE_CURRENT_BINARY_DIR}/qtcreator-project.icns"
- PROPERTIES
- MACOSX_PACKAGE_LOCATION "Resources"
+ qtc_copy_to_builddir(copy_icns
+ DESTINATION ${IDE_DATA_PATH}
+ FILES
+ ${CMAKE_CURRENT_BINARY_DIR}/qtcreator.icns
+ ${CMAKE_CURRENT_BINARY_DIR}/qtcreator-project.icns
+ )
+ install(
+ FILES
+ ${CMAKE_CURRENT_BINARY_DIR}/qtcreator.icns
+ ${CMAKE_CURRENT_BINARY_DIR}/qtcreator-project.icns
+ DESTINATION ${IDE_DATA_PATH}
)
endif()