aboutsummaryrefslogtreecommitdiffstats
path: root/src/app/CMakeLists.txt
diff options
context:
space:
mode:
authorCristian Adam <cristian.adam@qt.io>2021-06-24 17:44:14 +0200
committerCristian Adam <cristian.adam@qt.io>2021-06-25 14:24:41 +0000
commitf8a77287bfc74d1cb2e25eb510bfa9f97ca5bc8b (patch)
tree1728db1782fc40c8d730b87ff0af886aaaa28dd7 /src/app/CMakeLists.txt
parent6d26f4f5b0a29c11b4fe33c630a62dae4f8eded8 (diff)
CMakePM: Add support for qtc_runnable feature
This will allow for the Qt Creator's CMake build only qtcreator target to be selected as runnable. Similar to qmake's qtc_runnable or Qbs's qtcRunnable features. Fixes: QTCREATORBUG-25908 Change-Id: I6416873d0ad9cfec4960d98fc4b289ec98cc58b1 Reviewed-by: Eike Ziller <eike.ziller@qt.io>
Diffstat (limited to 'src/app/CMakeLists.txt')
-rw-r--r--src/app/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/app/CMakeLists.txt b/src/app/CMakeLists.txt
index b08211cf57..43650cab5a 100644
--- a/src/app/CMakeLists.txt
+++ b/src/app/CMakeLists.txt
@@ -17,6 +17,7 @@ add_qtc_executable(qtcreator
MACOSX_BUNDLE ON
OUTPUT_NAME "${IDE_APP_TARGET}"
DESTINATION "${IDE_APP_PATH}"
+ QTC_RUNNABLE
)
if (NOT TARGET qtcreator)