aboutsummaryrefslogtreecommitdiffstats
path: root/src/libs/3rdparty/cplusplus/CMakeLists.txt
diff options
context:
space:
mode:
authorMarcus Tillmanns <marcus.tillmanns@qt.io>2022-08-04 11:22:23 +0200
committerMarcus Tillmanns <marcus.tillmanns@qt.io>2022-08-04 10:22:06 +0000
commit3a53eebcfd64fb718e75febef63fa76e196c4868 (patch)
tree64f84d834da7c77e914ff6d103819c16d24ade1e /src/libs/3rdparty/cplusplus/CMakeLists.txt
parent5fcb459d6b2bbbd807803313de5e004df84ab436 (diff)
cplusplus: Disable warning
Change-Id: I08f3b40afc50903304627aeb788c60fcbafdd288 Reviewed-by: hjk <hjk@qt.io>
Diffstat (limited to 'src/libs/3rdparty/cplusplus/CMakeLists.txt')
-rw-r--r--src/libs/3rdparty/cplusplus/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/libs/3rdparty/cplusplus/CMakeLists.txt b/src/libs/3rdparty/cplusplus/CMakeLists.txt
index 41c653aa48..e7b9fedd0b 100644
--- a/src/libs/3rdparty/cplusplus/CMakeLists.txt
+++ b/src/libs/3rdparty/cplusplus/CMakeLists.txt
@@ -56,4 +56,8 @@ if(TARGET 3rd_cplusplus)
target_precompile_headers(3rd_cplusplus PRIVATE
"${QtCreator_SOURCE_DIR}/src/shared/qtcreator_gui_pch.h")
endif()
+
+ if(UNIX)
+ target_compile_options(3rd_cplusplus PRIVATE "-Wno-unused-variable")
+ endif()
endif()