aboutsummaryrefslogtreecommitdiffstats
path: root/src/libs/CMakeLists.txt
diff options
context:
space:
mode:
authorEike Ziller <eike.ziller@qt.io>2022-02-10 08:52:32 +0100
committerEike Ziller <eike.ziller@qt.io>2022-02-10 16:32:42 +0000
commit3ba00ac39f84dbc2509bebca4276b1b23fd73823 (patch)
tree7b6b94850e9979231b469cd83ffb0b7be19c81bd /src/libs/CMakeLists.txt
parent652639327f35003c0f46a93a8e576d5f4e3fdf89 (diff)
CMake build: Allow adding RPATHs via CMAKE_(BUILD|INSTALL)_RPATH
Prepend our own relative RPATHs to CMAKE_INSTALL_RPATH (or CMAKE_BUILD_RPATH respectively) instead of overriding them completely. That allows adding an RPATH to e.g. a self-compiled and separately installed Qt to the installed Qt Creator. Fixes: QTCREATORBUG-27008 Change-Id: I8cd9167fdf5ba9838850fcfab8135da9b79e6695 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/libs/CMakeLists.txt')
-rw-r--r--src/libs/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/libs/CMakeLists.txt b/src/libs/CMakeLists.txt
index aee880b4dd..b4ef8af90c 100644
--- a/src/libs/CMakeLists.txt
+++ b/src/libs/CMakeLists.txt
@@ -42,8 +42,8 @@ if(EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/qlitehtml/src/CMakeLists.txt)
#qtc_enable_separate_debug_info(qlitehtml "${IDE_LIBRARY_PATH}")
qtc_output_binary_dir(_output_binary_dir)
set_target_properties(qlitehtml PROPERTIES
- BUILD_RPATH "${_LIB_RPATH}"
- INSTALL_RPATH "${_LIB_RPATH}"
+ BUILD_RPATH "${_LIB_RPATH};${CMAKE_BUILD_RPATH}"
+ INSTALL_RPATH "${_LIB_RPATH};${CMAKE_INSTALL_RPATH}"
RUNTIME_OUTPUT_DIRECTORY "${_output_binary_dir}/${IDE_BIN_PATH}"
LIBRARY_OUTPUT_DIRECTORY "${_output_binary_dir}/${IDE_LIBRARY_PATH}"
ARCHIVE_OUTPUT_DIRECTORY "${_output_binary_dir}/${IDE_LIBRARY_ARCHIVE_PATH}"