aboutsummaryrefslogtreecommitdiffstats
path: root/src/libs/CMakeLists.txt
diff options
context:
space:
mode:
authorMarco Bubke <marco.bubke@qt.io>2023-06-21 15:49:38 +0200
committerMarco Bubke <marco.bubke@qt.io>2023-06-22 10:19:50 +0000
commit44565bc39ba06a7daace1619289e60db7f9c99a7 (patch)
tree221deaf7f175703edb15b76c34a26b8ddfd9df75 /src/libs/CMakeLists.txt
parentaef755bc16c919437230eede3ac93fc55ca62c2c (diff)
GoogleTest: Hard wire google tests
There were problems with older google test versions which were found instead. Now the google test version is always the same and there cannot be "strange" compile bugs. Change-Id: Ib3dc74d1abbe369fb37a4ee5616011d8e3696c01 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Eike Ziller <eike.ziller@qt.io>
Diffstat (limited to 'src/libs/CMakeLists.txt')
-rw-r--r--src/libs/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/libs/CMakeLists.txt b/src/libs/CMakeLists.txt
index de2d2b01ef..73a554bae8 100644
--- a/src/libs/CMakeLists.txt
+++ b/src/libs/CMakeLists.txt
@@ -22,6 +22,10 @@ if (WITH_QMLDESIGNER)
add_subdirectory(qmlpuppetcommunication)
endif()
+if (WITH_TESTS)
+ add_subdirectory(googletest)
+endif()
+
if(EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/qlitehtml/src/CMakeLists.txt)
option(BUILD_LIBRARY_QLITEHTML "Build library qlitehtml." ${BUILD_LIBRARIES_BY_DEFAULT})
set(QLITEHTML_VERSION_COMPAT ${IDE_VERSION_COMPAT} CACHE STRING "")