aboutsummaryrefslogtreecommitdiffstats
path: root/src/libs/CMakeLists.txt
diff options
context:
space:
mode:
authorEike Ziller <eike.ziller@qt.io>2021-03-23 17:54:06 +0100
committerEike Ziller <eike.ziller@qt.io>2021-04-06 10:59:27 +0000
commit4b3a7463328b657650da873cd485bfd5ced9c247 (patch)
treeda6ae4f228b30365fc0a6bcfcc68af03cfb4041f /src/libs/CMakeLists.txt
parent16cb026b8bfd8ff25643c7bc1f552c550773d6e5 (diff)
CMake build: Fix remaining issues with Devel package
On Linux (and Windows) we should not create toplevel files (README.md etc) or directories (doc/, scripts/ etc). On macOS, move the whole Devel package contents into the app bundle, because that is installed toplevel in the Qt installers, and we shouldn't even create include/, lib/ or any other directory at the toplevel at all. Since the prefix path must now point to the Resources folder inside the app bundle, adapt build_plugin.py to also accept --qtc-path pointing to the app bundle (Qt Creator.app) itself, and also to the app bundles parent directory. Adapt the Qt Creator plugin project template similarly. Task-number: QTCREATORBUG-25414 Fixes: QTCREATORBUG-25415 Change-Id: Ic756237fb920b54b1ec95d076649ad947b39a7e8 Reviewed-by: Cristian Adam <cristian.adam@qt.io>
Diffstat (limited to 'src/libs/CMakeLists.txt')
-rw-r--r--src/libs/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/libs/CMakeLists.txt b/src/libs/CMakeLists.txt
index bdcd9aabc9..7907d8272a 100644
--- a/src/libs/CMakeLists.txt
+++ b/src/libs/CMakeLists.txt
@@ -28,7 +28,7 @@ if(EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/qlitehtml/src/CMakeLists.txt)
set(QLITEHTML_EXPORT QtCreator)
set(QLITEHTML_DEVEL_COMPONENT Devel)
set(QLITEHTML_DEVEL_EXCLUDE_FROM_ALL ON)
- set(QLITEHTML_HEADER_PATH "include/src/lib/qlitehtml")
+ set(QLITEHTML_HEADER_PATH "${IDE_HEADER_INSTALL_PATH}/src/lib/qlitehtml")
add_subdirectory(qlitehtml/src)
endif()
if(TARGET qlitehtml)