aboutsummaryrefslogtreecommitdiffstats
path: root/src/libs/CMakeLists.txt
diff options
context:
space:
mode:
authorMarco Bubke <marco.bubke@qt.io>2022-11-02 13:58:34 +0100
committerMarco Bubke <marco.bubke@qt.io>2022-11-09 12:29:38 +0000
commit63022d08ea8f9f04a75d301602e639b83b1b7396 (patch)
tree99fbbfeafcb1ad0b4600f5d63b8071678894e8a5 /src/libs/CMakeLists.txt
parentac526d326cab6f19955cec4e19c73bc309bd96c8 (diff)
QmlDesigner: QmlPuppet as standalone tool
The qmlpuppet is now a standalone tool. There is new a library too with the communication code. That is shared between the designer and the puppet. It's in a .cmake file so it can be included by the standalone tool if it is not part of a designer build. Task-number: QDS-5879 Change-Id: I2bc2a0b463fbb3e0c8c23d182abfd368cf87e968 Reviewed-by: Thomas Hartmann <thomas.hartmann@qt.io> Reviewed-by: <github-actions-qt-creator@cristianadam.eu> Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org>
Diffstat (limited to 'src/libs/CMakeLists.txt')
-rw-r--r--src/libs/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/libs/CMakeLists.txt b/src/libs/CMakeLists.txt
index 7265810737..0f2b340939 100644
--- a/src/libs/CMakeLists.txt
+++ b/src/libs/CMakeLists.txt
@@ -15,6 +15,7 @@ add_subdirectory(glsl)
add_subdirectory(languageserverprotocol)
add_subdirectory(sqlite)
add_subdirectory(tracing)
+add_subdirectory(qmlpuppetcommunication)
add_subdirectory(qtcreatorcdbext)