aboutsummaryrefslogtreecommitdiffstats
path: root/src/libs/CMakeLists.txt
diff options
context:
space:
mode:
authorEike Ziller <eike.ziller@qt.io>2023-08-30 15:04:29 +0200
committerEike Ziller <eike.ziller@qt.io>2023-09-12 07:32:07 +0000
commitdab19c4a8c60ed482d1082064d23609a1acf4e5e (patch)
tree8b4279bffe8b1b58ffb81ef95845c53459fad1fb /src/libs/CMakeLists.txt
parent66c8eda94397f929cca2f8f6697aeeba396e1a5d (diff)
Use Nanotrace to generate startup performance report
Add various trace points to the code, including the plugin initialization methods (centrally in plugin manager), code that is scheduled on the event loop with QTimer::singleShot or QMetaObject::invokeMethod during initialization, and code that is triggered from ICore::coreOpened Can be turned on by configuring with `BUILD_LIBRARY_NANOTRACE=ON` Run with `-trace <file>` to write trace file. If Nanotrace is not built, the added code expands to nothing. Changes in Nanotrace: - turned generated data to microseconds instead of nanoseconds, because that is what Chrome tracing expects - fixed serialization of duration (needs to be an item of the event, not in a "arg" subitem) - fixed shutdown() to reset the initEvent Change-Id: I994de82023b820d771e1be0a859ebd8da0b73d4d Reviewed-by: <github-actions-qt-creator@cristianadam.eu> Reviewed-by: Alessandro Portale <alessandro.portale@qt.io>
Diffstat (limited to 'src/libs/CMakeLists.txt')
-rw-r--r--src/libs/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/libs/CMakeLists.txt b/src/libs/CMakeLists.txt
index 73a554bae8..536e373494 100644
--- a/src/libs/CMakeLists.txt
+++ b/src/libs/CMakeLists.txt
@@ -1,5 +1,6 @@
add_subdirectory(3rdparty)
+add_subdirectory(nanotrace)
add_subdirectory(advanceddockingsystem)
add_subdirectory(aggregation)
add_subdirectory(cplusplus)
@@ -8,7 +9,6 @@ add_subdirectory(glsl)
add_subdirectory(languageserverprotocol)
add_subdirectory(languageutils)
add_subdirectory(modelinglib)
-add_subdirectory(nanotrace)
add_subdirectory(qmldebug)
add_subdirectory(qmleditorwidgets)
add_subdirectory(qmljs)