aboutsummaryrefslogtreecommitdiffstats
path: root/src/libs/CMakeLists.txt
diff options
context:
space:
mode:
authorKnud Dollereder <knud.dollereder@qt.io>2021-10-12 12:07:44 +0200
committerKnud Dollereder <knud.dollereder@qt.io>2022-01-25 14:25:04 +0000
commitebac821e9ee3b1e9e1ba73610346c2ea1ad92523 (patch)
treef1e84622ac74d22cca648d9c32b16fa50c75a3f5 /src/libs/CMakeLists.txt
parenta03a50a262760d870433347e5e397f1577ba70cd (diff)
Replace minitrace with nanotrace
Minitrace is a library to produce json traces suitable for chromes built-in trace viewer. Unfortunately it lacks the ability to add custom arguments to the json files which is needed in our case in order to examine Design Studios state from within the evaluating python script. Nanotrace is a rewrite of minitrace that adds this ability. Additional benefits are higher precision and the fact that it is written in c++. Change-Id: Id2610b93188483d88547369c3fa8dacbe4dee9f7 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Thomas Hartmann <thomas.hartmann@qt.io>
Diffstat (limited to 'src/libs/CMakeLists.txt')
-rw-r--r--src/libs/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/libs/CMakeLists.txt b/src/libs/CMakeLists.txt
index df1826f734..aee880b4dd 100644
--- a/src/libs/CMakeLists.txt
+++ b/src/libs/CMakeLists.txt
@@ -7,6 +7,7 @@ add_subdirectory(utils)
add_subdirectory(languageutils)
add_subdirectory(cplusplus)
add_subdirectory(modelinglib)
+add_subdirectory(nanotrace)
add_subdirectory(qmljs)
add_subdirectory(qmldebug)
add_subdirectory(qmleditorwidgets)