aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/CMakeLists.txt
diff options
context:
space:
mode:
authorAlessandro Portale <alessandro.portale@qt.io>2022-12-06 12:36:26 +0100
committerAlessandro Portale <alessandro.portale@qt.io>2023-03-10 08:04:45 +0000
commit0613a492f375714b1f8807839c87858c1a665efa (patch)
tree3413bfb3e70c660b35fc74e244173b0ff23aefb4 /src/plugins/CMakeLists.txt
parent3fae8fdc36bf9d1a489e70618808632922dd47a4 (diff)
Vcpkg: Initial commit
This introduces the vcpkg support plugin. Initial features are: - Options page for defining vcpkg installation location - Search dialog for searching/selecting a package (incl. parsing autotest) - TextEditor that shows search/options toolbuttons - File wizard that creates a vcpkg.json manifest Change-Id: I098784100c869e0bb2ed6f60db4dedad559a142a Reviewed-by: hjk <hjk@qt.io>
Diffstat (limited to 'src/plugins/CMakeLists.txt')
-rw-r--r--src/plugins/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/plugins/CMakeLists.txt b/src/plugins/CMakeLists.txt
index 5e3ff9bb18a..02f13199140 100644
--- a/src/plugins/CMakeLists.txt
+++ b/src/plugins/CMakeLists.txt
@@ -27,6 +27,7 @@ add_subdirectory(help)
add_subdirectory(resourceeditor)
add_subdirectory(nim)
add_subdirectory(conan)
+add_subdirectory(vcpkg)
# Level 4: (only depends on Level 3 and below)
add_subdirectory(classview)