aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/CMakeLists.txt
diff options
context:
space:
mode:
authorAlessandro Portale <alessandro.portale@qt.io>2023-11-20 12:42:48 +0100
committerAlessandro Portale <alessandro.portale@qt.io>2023-11-20 16:14:36 +0000
commit400dee55ef5f1229ef569b28bebb8d23f19b2f3a (patch)
treecc35f469dc2ee71c19093dde1ecea968a6989bcc /src/plugins/CMakeLists.txt
parentb26c43f133fd692e6ab7d8fba309f8e5204fd3ec (diff)
CMake build system: Push some plugins "dependecy levels" up
The higher the "level", the more dependencies. Some plugins from that level have less dependencies than their level indicates and can "move up". Change-Id: I2735162ab0b64096f21bc025e3d6ecc7427a5bf4 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Eike Ziller <eike.ziller@qt.io>
Diffstat (limited to 'src/plugins/CMakeLists.txt')
-rw-r--r--src/plugins/CMakeLists.txt17
1 files changed, 8 insertions, 9 deletions
diff --git a/src/plugins/CMakeLists.txt b/src/plugins/CMakeLists.txt
index 15416d790d6..5d07d99608f 100644
--- a/src/plugins/CMakeLists.txt
+++ b/src/plugins/CMakeLists.txt
@@ -22,12 +22,15 @@ add_subdirectory(silversearcher)
# Level 3: (only depends on Level 2 and below)
add_subdirectory(axivion)
+add_subdirectory(compilerexplorer)
add_subdirectory(cppeditor)
add_subdirectory(haskell)
add_subdirectory(help)
add_subdirectory(resourceeditor)
add_subdirectory(nim)
add_subdirectory(conan)
+add_subdirectory(saferenderer)
+add_subdirectory(terminal)
add_subdirectory(vcpkg)
# Level 4: (only depends on Level 3 and below)
@@ -39,10 +42,12 @@ add_subdirectory(todo)
add_subdirectory(vcsbase)
# Level 5:
+add_subdirectory(autotoolsprojectmanager)
add_subdirectory(bazaar)
add_subdirectory(beautifier)
add_subdirectory(clangformat)
add_subdirectory(clearcase)
+add_subdirectory(cmakeprojectmanager)
add_subdirectory(cvs)
add_subdirectory(designer)
add_subdirectory(docker)
@@ -62,27 +67,27 @@ add_subdirectory(languageclient)
if (WITH_QMLDESIGNER)
add_subdirectory(qmldesignerbase)
endif()
+add_subdirectory(webassembly)
# Level 6:
-add_subdirectory(cmakeprojectmanager)
add_subdirectory(debugger)
add_subdirectory(coco)
+add_subdirectory(copilot)
add_subdirectory(gitlab)
if (WITH_QMLDESIGNER)
add_subdirectory(qmlprojectmanager)
endif()
+add_subdirectory(python)
# Level 7:
add_subdirectory(android)
add_subdirectory(autotest)
-add_subdirectory(autotoolsprojectmanager)
add_subdirectory(baremetal)
add_subdirectory(clangcodemodel)
add_subdirectory(clangtools)
add_subdirectory(cppcheck)
add_subdirectory(incredibuild)
add_subdirectory(ios)
-add_subdirectory(python)
add_subdirectory(qmljseditor)
add_subdirectory(qmlpreview)
add_subdirectory(qmlprofiler)
@@ -108,10 +113,4 @@ if (WITH_QMLDESIGNER)
add_subdirectory(insight)
endif()
add_subdirectory(qnx)
-add_subdirectory(webassembly)
add_subdirectory(mcusupport)
-add_subdirectory(saferenderer)
-add_subdirectory(copilot)
-add_subdirectory(terminal)
-
-add_subdirectory(compilerexplorer)