aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/clangtools/CMakeLists.txt
diff options
context:
space:
mode:
authorNikolai Kosjar <nikolai.kosjar@qt.io>2019-11-04 14:44:36 +0100
committerNikolai Kosjar <nikolai.kosjar@qt.io>2019-12-04 14:07:04 +0000
commit07ec6de8d94e1498407158525baba4be441a791c (patch)
tree78f7fd864dcd7857f86e020c7485871501c928b4 /src/plugins/clangtools/CMakeLists.txt
parent92bb42dd36394162a9badecf029234e1c343b5a7 (diff)
ClangTools: Improve filtering
Replace the filter line edit in the toolbar by a tool button that pop ups a dialog. In the dialog, the available checkers can be selectd/unselected to filter the diagnostic view. Also, the diagnostic view can be limited to diagnostics with fixits so that these can be selected and applied as the next step. For convience, add also some context menu entries to modify the filter with regard to the current diagnostic. Change-Id: Ifba3028805840658d72a39516c2b02da9864d4a6 Reviewed-by: Cristian Adam <cristian.adam@qt.io>
Diffstat (limited to 'src/plugins/clangtools/CMakeLists.txt')
-rw-r--r--src/plugins/clangtools/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/plugins/clangtools/CMakeLists.txt b/src/plugins/clangtools/CMakeLists.txt
index c45e7afa5a..88b25830d7 100644
--- a/src/plugins/clangtools/CMakeLists.txt
+++ b/src/plugins/clangtools/CMakeLists.txt
@@ -31,6 +31,7 @@ add_qtc_plugin(ClangTools
clazychecks.ui
diagnosticconfigswidget.cpp diagnosticconfigswidget.h
executableinfo.cpp executableinfo.h
+ filterdialog.cpp filterdialog.h filterdialog.ui
runsettingswidget.cpp runsettingswidget.h runsettingswidget.ui
settingswidget.cpp settingswidget.h settingswidget.ui
tidychecks.ui