aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/clangtools/CMakeLists.txt
diff options
context:
space:
mode:
authorNikolai Kosjar <nikolai.kosjar@qt.io>2019-07-30 15:26:31 +0200
committerNikolai Kosjar <nikolai.kosjar@qt.io>2019-08-30 08:42:22 +0000
commit0ba729e527da37f7c5d7fbc59247971df3da7d8a (patch)
treef6397a18ab4a7850b656f7b6e7a68f3d8a4e49ae /src/plugins/clangtools/CMakeLists.txt
parentd663b8e406c89585f123207d6e07832d1818e53b (diff)
Import YAML-Parser yaml-cpp
Version: tags/yaml-cpp-0.6.2 License: MIT yaml-cpp requires c++11 and since yaml-cpp 0.6 there is no dependency on boost anymore. A YAML parser is needed for the ClangTools plugin to parse exported diagnostics from clang-tidy/clazy: $ clang-tidy -export-fixes=/tmp/tidy.yaml source.cpp The imported source is stripped of unneeded files as documented with src/libs/3rdparty/yaml-cpp/patches/0001-yaml-cpp-Strip-unneeded-sources.patch (generated with "git format-patch -D") Change-Id: Ib0a521b5aff4b1cd058eb480bfb99fde4b320dc7 Reviewed-by: Eike Ziller <eike.ziller@qt.io>
Diffstat (limited to 'src/plugins/clangtools/CMakeLists.txt')
-rw-r--r--src/plugins/clangtools/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/plugins/clangtools/CMakeLists.txt b/src/plugins/clangtools/CMakeLists.txt
index 9e767418f0..ba6c1bce62 100644
--- a/src/plugins/clangtools/CMakeLists.txt
+++ b/src/plugins/clangtools/CMakeLists.txt
@@ -2,9 +2,11 @@ if (WITH_TESTS)
set(TST_COMPONENT QmakeProjectManager)
endif()
+find_package(yaml-cpp QUIET MODULE)
+
add_qtc_plugin(ClangTools
- CONDITION TARGET libclang
- DEPENDS ClangSupport libclang
+ CONDITION TARGET libclang AND TARGET yaml-cpp
+ DEPENDS ClangSupport libclang yaml-cpp
PLUGIN_DEPENDS Core Debugger CppTools ${TST_COMPONENT}
INCLUDES ${CLANG_INCLUDE_DIRS}
SOURCES