aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/clangtools/CMakeLists.txt
diff options
context:
space:
mode:
authorEike Ziller <eike.ziller@qt.io>2020-03-26 13:20:58 +0100
committerEike Ziller <eike.ziller@qt.io>2020-03-30 06:16:37 +0000
commit27f6e838ee2965b508bd6422dac76817b4070bdb (patch)
tree36efe18ebc941f69af48f11cf7f3e1ba4aa8dad8 /src/plugins/clangtools/CMakeLists.txt
parent99cd623fa7b9d57c78c9b59d37bc7e12f74bbd34 (diff)
ClangTools: Add "Analyze Current File" to Tools menu and context menu
Add the action to "Tools > C++" and the C++ editor context menu. Task-number: QTCREATORBUG-23348 Change-Id: I650e4d10e07ba227c6f89ab660ce7fa81263172e Reviewed-by: David Schulz <david.schulz@qt.io>
Diffstat (limited to 'src/plugins/clangtools/CMakeLists.txt')
-rw-r--r--src/plugins/clangtools/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/plugins/clangtools/CMakeLists.txt b/src/plugins/clangtools/CMakeLists.txt
index 88b25830d7..9831046b5f 100644
--- a/src/plugins/clangtools/CMakeLists.txt
+++ b/src/plugins/clangtools/CMakeLists.txt
@@ -8,6 +8,7 @@ add_qtc_plugin(ClangTools
CONDITION TARGET libclang AND TARGET yaml-cpp
DEPENDS ClangSupport libclang yaml-cpp
PLUGIN_DEPENDS Core Debugger CppTools ${TST_COMPONENT}
+ PLUGIN_RECOMMENDS CppEditor
INCLUDES ${CLANG_INCLUDE_DIRS}
SOURCES
clangfileinfo.h