aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/coreplugin/CMakeLists.txt
diff options
context:
space:
mode:
authorEike Ziller <eike.ziller@qt.io>2020-06-17 09:14:47 +0200
committerEike Ziller <eike.ziller@qt.io>2020-06-18 05:58:23 +0000
commit1b431fe271e04b111d475654c7ea003981cba989 (patch)
tree4bd5590f83151e654a66279cc950d0c94424e3c0 /src/plugins/coreplugin/CMakeLists.txt
parent5ebe34a33205199bd755283ed0a8c30870dadab8 (diff)
Move Id from Core to Utils
And add a compatibility wrapper for Core::Id, so we don't have to rename all occurrences from Core::Id to Utils::Id. This allows us to use Id also in Utils, which makes it possible to e.g. move Core::InfoBar to Utils without work arounds. Change-Id: I5555d05b4e52f09d501dbfe5d91252a982a97c61 Reviewed-by: Marco Bubke <marco.bubke@qt.io> Reviewed-by: Orgad Shaneh <orgads@gmail.com> Reviewed-by: David Schulz <david.schulz@qt.io> Reviewed-by: hjk <hjk@qt.io> Reviewed-by: Alessandro Portale <alessandro.portale@qt.io> Reviewed-by: André Hartmann <aha_1980@gmx.de>
Diffstat (limited to 'src/plugins/coreplugin/CMakeLists.txt')
-rw-r--r--src/plugins/coreplugin/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/plugins/coreplugin/CMakeLists.txt b/src/plugins/coreplugin/CMakeLists.txt
index 66e8eff963..937a9b0bef 100644
--- a/src/plugins/coreplugin/CMakeLists.txt
+++ b/src/plugins/coreplugin/CMakeLists.txt
@@ -85,7 +85,7 @@ add_qtc_plugin(Core
helpmanager.cpp helpmanager.h helpmanager_implementation.h
icontext.cpp icontext.h
icore.cpp icore.h
- id.cpp id.h
+ id.h
idocument.cpp idocument.h
idocumentfactory.cpp idocumentfactory.h
ifilewizardextension.h