aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/cppeditor/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Kandeler <christian.kandeler@qt.io>2021-08-30 10:58:08 +0200
committerChristian Kandeler <christian.kandeler@qt.io>2021-09-01 14:53:58 +0000
commit284817fae6514701902ccdb834c2faa46462f2e8 (patch)
tree44a8c7d9813dc110b61c4639036366c7696bd7e9 /src/plugins/cppeditor/CMakeLists.txt
parent3e1fa0f170d523971d2c3c12da15a6e291f56511 (diff)
Merge CppTools into CppEditor
There was no proper separation of responsibilities between these plugins. In particular, CppTools had lots of editor-related functionality, so it's not clear why it was separated out in the first place. In fact, for a lot of code, it seemed quite arbitrary where it was put (just one example: switchHeaderSource() was in CppTools, wheras switchDeclarationDefinition() was in CppEditor). Merging the plugins will enable us to get rid of various convoluted pseudo-abstractions that were only introduced to keep up the artificial separation. Change-Id: Iafc3bce625b4794f6d4aa03df6cddc7f2d26716a Reviewed-by: Christian Stenger <christian.stenger@qt.io>
Diffstat (limited to 'src/plugins/cppeditor/CMakeLists.txt')
-rw-r--r--src/plugins/cppeditor/CMakeLists.txt118
1 files changed, 116 insertions, 2 deletions
diff --git a/src/plugins/cppeditor/CMakeLists.txt b/src/plugins/cppeditor/CMakeLists.txt
index 551c705c2d..ae27d8f2ff 100644
--- a/src/plugins/cppeditor/CMakeLists.txt
+++ b/src/plugins/cppeditor/CMakeLists.txt
@@ -1,40 +1,139 @@
add_qtc_plugin(CppEditor
DEFINES CPPEDITOR_LIBRARY
- PLUGIN_DEPENDS Core CppTools ProjectExplorer TextEditor
+ DEPENDS Qt5::Network Qt5::Xml
+ PUBLIC_DEPENDS CPlusPlus ClangSupport Qt5::Widgets
+ PLUGIN_DEPENDS Core ProjectExplorer TextEditor
PLUGIN_TEST_DEPENDS QbsProjectManager QmakeProjectManager
SOURCES
+ abstracteditorsupport.cpp abstracteditorsupport.h
+ abstractoverviewmodel.h
+ baseeditordocumentparser.cpp baseeditordocumentparser.h
+ baseeditordocumentprocessor.cpp baseeditordocumentprocessor.h
+ builtincursorinfo.cpp builtincursorinfo.h
+ builtineditordocumentparser.cpp builtineditordocumentparser.h
+ builtineditordocumentprocessor.cpp builtineditordocumentprocessor.h
+ builtinindexingsupport.cpp builtinindexingsupport.h
+ clangbasechecks.ui
+ clangdiagnosticconfig.cpp clangdiagnosticconfig.h
+ clangdiagnosticconfigsmodel.cpp clangdiagnosticconfigsmodel.h
+ clangdiagnosticconfigsselectionwidget.cpp clangdiagnosticconfigsselectionwidget.h
+ clangdiagnosticconfigswidget.cpp clangdiagnosticconfigswidget.h clangdiagnosticconfigswidget.ui
+ compileroptionsbuilder.cpp compileroptionsbuilder.h
cppautocompleter.cpp cppautocompleter.h
+ cppbuiltinmodelmanagersupport.cpp cppbuiltinmodelmanagersupport.h
+ cppcanonicalsymbol.cpp cppcanonicalsymbol.h
+ cppchecksymbols.cpp cppchecksymbols.h
+ cppclassesfilter.cpp cppclassesfilter.h
+ cppcodeformatter.cpp cppcodeformatter.h
cppcodemodelinspectordialog.cpp cppcodemodelinspectordialog.h cppcodemodelinspectordialog.ui
+ cppcodemodelinspectordumper.cpp cppcodemodelinspectordumper.h
+ cppcodemodelsettings.cpp cppcodemodelsettings.h
+ cppcodemodelsettingspage.cpp cppcodemodelsettingspage.h cppcodemodelsettingspage.ui
+ cppcodestylepreferences.cpp cppcodestylepreferences.h
+ cppcodestylepreferencesfactory.cpp cppcodestylepreferencesfactory.h
+ cppcodestylesettings.cpp cppcodestylesettings.h
+ cppcodestylesettingspage.cpp cppcodestylesettingspage.h cppcodestylesettingspage.ui
+ cppcodestylesnippets.h
+ cppcompletionassist.cpp cppcompletionassist.h
+ cppcompletionassistprocessor.cpp cppcompletionassistprocessor.h
+ cppcompletionassistprovider.cpp cppcompletionassistprovider.h
+ cppcurrentdocumentfilter.cpp cppcurrentdocumentfilter.h
+ cppcursorinfo.h
cppdocumentationcommenthelper.cpp cppdocumentationcommenthelper.h
+ cppdoxygen.cpp cppdoxygen.h
cppeditor.cpp cppeditor.h
cppeditor.qrc
cppeditor_global.h
+ cppeditor_utils.h
cppeditorconstants.h
cppeditordocument.cpp cppeditordocument.h
cppeditorenums.h
+ cppeditoroutline.cpp cppeditoroutline.h
cppeditorplugin.cpp cppeditorplugin.h
cppeditorwidget.cpp cppeditorwidget.h
+ cppeditorwidgetinterface.h
+ cppelementevaluator.cpp cppelementevaluator.h
+ cppfileiterationorder.cpp cppfileiterationorder.h
+ cppfilesettingspage.cpp cppfilesettingspage.h cppfilesettingspage.ui
+ cppfindreferences.cpp cppfindreferences.h
+ cppfollowsymbolundercursor.cpp cppfollowsymbolundercursor.h
cppfunctiondecldeflink.cpp cppfunctiondecldeflink.h
+ cppfunctionsfilter.cpp cppfunctionsfilter.h
cpphighlighter.cpp cpphighlighter.h
+ cpphoverhandler.cpp cpphoverhandler.h
cppincludehierarchy.cpp cppincludehierarchy.h
+ cppincludesfilter.cpp cppincludesfilter.h
+ cppindexingsupport.cpp cppindexingsupport.h
cppinsertvirtualmethods.cpp cppinsertvirtualmethods.h
cpplocalrenaming.cpp cpplocalrenaming.h
+ cpplocalsymbols.cpp cpplocalsymbols.h
+ cpplocatordata.cpp cpplocatordata.h
+ cpplocatorfilter.cpp cpplocatorfilter.h
cppminimizableinfobars.cpp cppminimizableinfobars.h
+ cppmodelmanager.cpp cppmodelmanager.h
+ cppmodelmanagersupport.cpp cppmodelmanagersupport.h
cppoutline.cpp cppoutline.h
+ cppoverviewmodel.cpp cppoverviewmodel.h
cppparsecontext.cpp cppparsecontext.h
+ cpppointerdeclarationformatter.cpp cpppointerdeclarationformatter.h
cpppreprocessordialog.cpp cpppreprocessordialog.h cpppreprocessordialog.ui
+ cppprojectfile.cpp cppprojectfile.h
+ cppprojectfilecategorizer.cpp cppprojectfilecategorizer.h
+ cppprojectinfogenerator.cpp cppprojectinfogenerator.h
+ cppprojectpartchooser.cpp cppprojectpartchooser.h
+ cppprojectupdater.cpp cppprojectupdater.h
+ cppprojectupdaterinterface.h
+ cppqtstyleindenter.cpp cppqtstyleindenter.h
cppquickfix.cpp cppquickfix.h
cppquickfixassistant.cpp cppquickfixassistant.h
cppquickfixes.cpp cppquickfixes.h
cppquickfixprojectsettings.cpp cppquickfixprojectsettings.h
cppquickfixprojectsettingswidget.cpp cppquickfixprojectsettingswidget.h
- cppquickfixprojectsettingswidget.ui
+ cppquickfixprojectsettingswidget.ui
cppquickfixsettings.cpp cppquickfixsettings.h
cppquickfixsettingspage.cpp cppquickfixsettingspage.h
cppquickfixsettingswidget.cpp cppquickfixsettingswidget.h cppquickfixsettingswidget.ui
+ cpprefactoringchanges.cpp cpprefactoringchanges.h
+ cpprefactoringengine.cpp cpprefactoringengine.h
+ cppselectionchanger.cpp cppselectionchanger.h
+ cppsemanticinfo.h
+ cppsemanticinfoupdater.cpp cppsemanticinfoupdater.h
+ cppsourceprocessor.cpp cppsourceprocessor.h
+ cppsymbolinfo.h
+ cpptoolsbridge.cpp cpptoolsbridge.h
+ cpptoolsbridgeinterface.h
+ cpptoolsbridgeqtcreatorimplementation.cpp cpptoolsbridgeqtcreatorimplementation.h
+ cpptoolsjsextension.cpp cpptoolsjsextension.h
+ cpptoolsreuse.cpp cpptoolsreuse.h
+ cpptoolssettings.cpp cpptoolssettings.h
cpptypehierarchy.cpp cpptypehierarchy.h
cppuseselectionsupdater.cpp cppuseselectionsupdater.h
+ cppvirtualfunctionassistprovider.cpp cppvirtualfunctionassistprovider.h
+ cppvirtualfunctionproposalitem.cpp cppvirtualfunctionproposalitem.h
+ cppworkingcopy.cpp cppworkingcopy.h
+ cursorineditor.h
+ doxygengenerator.cpp doxygengenerator.h
+ editordocumenthandle.cpp editordocumenthandle.h
+ followsymbolinterface.h
+ functionutils.cpp functionutils.h
+ generatedcodemodelsupport.cpp generatedcodemodelsupport.h
+ headerpathfilter.cpp headerpathfilter.h
+ includeutils.cpp includeutils.h
+ indexitem.cpp indexitem.h
+ insertionpointlocator.cpp insertionpointlocator.h
+ projectinfo.cpp projectinfo.h
+ projectpart.cpp projectpart.h
+ refactoringengineinterface.h
resourcepreviewhoverhandler.cpp resourcepreviewhoverhandler.h
+ searchsymbols.cpp searchsymbols.h
+ semantichighlighter.cpp semantichighlighter.h
+ senddocumenttracker.cpp senddocumenttracker.h
+ stringtable.cpp stringtable.h
+ symbolfinder.cpp symbolfinder.h
+ symbolsfindfilter.cpp symbolsfindfilter.h
+ typehierarchybuilder.cpp typehierarchybuilder.h
+ usages.h
+ wrappablelineedit.cpp wrappablelineedit.h
EXPLICIT_MOC
cppeditor.h
cppquickfixsettingswidget.h
@@ -44,13 +143,28 @@ add_qtc_plugin(CppEditor
extend_qtc_plugin(CppEditor
CONDITION WITH_TESTS
SOURCES
+ compileroptionsbuilder_test.cpp compileroptionsbuilder_test.h
+ cppcodegen_test.cpp cppcodegen_test.h
+ cppcompletion_test.cpp cppcompletion_test.h
cppdoxygen_test.cpp cppdoxygen_test.h
cppeditortestcase.cpp cppeditortestcase.h
+ cppheadersource_test.cpp cppheadersource_test.h
cppincludehierarchy_test.cpp cppincludehierarchy_test.h
+ cpplocalsymbols_test.cpp cpplocalsymbols_test.h
+ cpplocatorfilter_test.cpp cpplocatorfilter_test.h
+ cppmodelmanager_test.cpp cppmodelmanager_test.h
+ cpppointerdeclarationformatter_test.cpp cpppointerdeclarationformatter_test.h
cppquickfix_test.cpp cppquickfix_test.h
+ cppsourceprocessertesthelper.cpp cppsourceprocessertesthelper.h
+ cppsourceprocessor_test.cpp cppsourceprocessor_test.h
+ cpptoolstestcase.cpp cpptoolstestcase.h
cppuseselections_test.cpp cppuseselections_test.h
fileandtokenactions_test.cpp fileandtokenactions_test.h
followsymbol_switchmethoddecldef_test.cpp followsymbol_switchmethoddecldef_test.h
+ modelmanagertesthelper.cpp modelmanagertesthelper.h
+ projectinfo_test.cpp projectinfo_test.h
+ symbolsearcher_test.cpp symbolsearcher_test.h
+ typehierarchybuilder_test.cpp typehierarchybuilder_test.h
EXPLICIT_MOC
cppdoxygen_test.h
cppquickfix_test.h