aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/cppeditor/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Kandeler <christian.kandeler@qt.io>2024-03-15 16:02:50 +0100
committerChristian Kandeler <christian.kandeler@qt.io>2024-03-28 19:06:08 +0000
commit3ca0deef536d33163256fee9a50895f1ee5e4a75 (patch)
tree0a24461264862ae66ac3c07ef39ee40bc05d541c /src/plugins/cppeditor/CMakeLists.txt
parentfc8f1bc47df91e829c569cb5977677b835b86f88 (diff)
CppEditor: Move ClangdSettings into a dedicated set of files
They were originally put alongside the CppCodeModelSettings for simplicity, but there is no coupling (anymore?) between these two classes. Change-Id: Ic24df109b74a5b5c39de073c938c6de12f4aa319 Reviewed-by: <github-actions-qt-creator@cristianadam.eu> Reviewed-by: David Schulz <david.schulz@qt.io>
Diffstat (limited to 'src/plugins/cppeditor/CMakeLists.txt')
-rw-r--r--src/plugins/cppeditor/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/plugins/cppeditor/CMakeLists.txt b/src/plugins/cppeditor/CMakeLists.txt
index ec5ad89cea..93c37beaca 100644
--- a/src/plugins/cppeditor/CMakeLists.txt
+++ b/src/plugins/cppeditor/CMakeLists.txt
@@ -93,6 +93,7 @@ add_qtc_plugin(CppEditor
cppvirtualfunctionassistprovider.cpp cppvirtualfunctionassistprovider.h
cppvirtualfunctionproposalitem.cpp cppvirtualfunctionproposalitem.h
cppworkingcopy.cpp cppworkingcopy.h
+ clangdsettings.cpp clangdsettings.h
cursorineditor.h
doxygengenerator.cpp doxygengenerator.h
editordocumenthandle.cpp editordocumenthandle.h