aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/cppeditor/CMakeLists.txt
diff options
context:
space:
mode:
authorLeander Schulten <Leander.Schulten@rwth-aachen.de>2020-08-20 00:33:24 +0200
committerLeander Schulten <Leander.Schulten@rwth-aachen.de>2020-10-14 10:12:44 +0000
commit5b5ae971045adebe40209150cf9e1cac6cc62191 (patch)
treea289184954bb8e2cc6dd3e7d4471f45e24e9405a /src/plugins/cppeditor/CMakeLists.txt
parent7c58a4ac5b82903fae881922acdeac7cabc60692 (diff)
CppEditor: Introduce QuickFix settings and unify getter/setter generation
Introduces a QuickFix settings page where the generation of getters and setters can be customized. The settings can be saved into a file that can go into a VCS. All QuickFixes that generate getter/setter/signals/ Q_PROPERTIES now use the same backend. QuickFixes that generate getters/ setters are now extended to also generate signals and Q_PROPERTIES. Fixes: QTCREATORBUG-1532 Fixes: QTCREATORBUG-17941 Fixes: QTCREATORBUG-12678 Fixes: QTCREATORBUG-15779 Fixes: QTCREATORBUG-11620 Fixes: QTCREATORBUG-22707 Fixes: QTCREATORBUG-20157 Fixes: QTCREATORBUG-21804 Fixes: QTCREATORBUG-19814 Fixes: QTCREATORBUG-14622 Fixes: QTCREATORBUG-19803 Change-Id: I50ed2dad9b4a637fbd87b3e1f2856060ad0ad920 Reviewed-by: Christian Kandeler <christian.kandeler@qt.io>
Diffstat (limited to 'src/plugins/cppeditor/CMakeLists.txt')
-rw-r--r--src/plugins/cppeditor/CMakeLists.txt11
1 files changed, 10 insertions, 1 deletions
diff --git a/src/plugins/cppeditor/CMakeLists.txt b/src/plugins/cppeditor/CMakeLists.txt
index d2a55ca8cf..c038c8314d 100644
--- a/src/plugins/cppeditor/CMakeLists.txt
+++ b/src/plugins/cppeditor/CMakeLists.txt
@@ -25,10 +25,19 @@ add_qtc_plugin(CppEditor
cppquickfix.cpp cppquickfix.h
cppquickfixassistant.cpp cppquickfixassistant.h
cppquickfixes.cpp cppquickfixes.h
+ cppquickfixprojectsettings.cpp cppquickfixprojectsettings.h
+ cppquickfixprojectsettingswidget.cpp cppquickfixprojectsettingswidget.h
+ cppquickfixprojectsettingswidget.ui
+ cppquickfixsettings.cpp cppquickfixsettings.h
+ cppquickfixsettingspage.cpp cppquickfixsettingspage.h
+ cppquickfixsettingswidget.cpp cppquickfixsettingswidget.h cppquickfixsettingswidget.ui
cpptypehierarchy.cpp cpptypehierarchy.h
cppuseselectionsupdater.cpp cppuseselectionsupdater.h
resourcepreviewhoverhandler.cpp resourcepreviewhoverhandler.h
- EXPLICIT_MOC cppeditor.h
+ EXPLICIT_MOC
+ cppeditor.h
+ cppquickfixsettingswidget.h
+ cppquickfixprojectsettingswidget.h
)
extend_qtc_plugin(CppEditor