aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/cppeditor/CMakeLists.txt
diff options
context:
space:
mode:
authorhjk <hjk@qt.io>2024-01-25 17:08:14 +0100
committerhjk <hjk@qt.io>2024-01-26 12:44:53 +0000
commit7f061c723a7e96b988d7b9b56dea727c4ca6fd7b (patch)
tree94ae07dea8618623a7e7c80a14d691dcc6010b5c /src/plugins/cppeditor/CMakeLists.txt
parente71d16ef90ebf5983ac657aae42d52991de923e7 (diff)
CppEditor: Move CppHeaderSource implementation and test to same files
... and remove the now-empty cppeditorplugin.h Change-Id: Ia28b180c280ba7b10ce0f2826f2ac69d128a453c Reviewed-by: Christian Kandeler <christian.kandeler@qt.io>
Diffstat (limited to 'src/plugins/cppeditor/CMakeLists.txt')
-rw-r--r--src/plugins/cppeditor/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/plugins/cppeditor/CMakeLists.txt b/src/plugins/cppeditor/CMakeLists.txt
index c64817cfb0..ec5ad89cea 100644
--- a/src/plugins/cppeditor/CMakeLists.txt
+++ b/src/plugins/cppeditor/CMakeLists.txt
@@ -40,7 +40,7 @@ add_qtc_plugin(CppEditor
cppeditorconstants.h
cppeditordocument.cpp cppeditordocument.h
cppeditoroutline.cpp cppeditoroutline.h
- cppeditorplugin.cpp cppeditorplugin.h
+ cppeditorplugin.cpp
cppeditorwidget.cpp cppeditorwidget.h
cppelementevaluator.cpp cppelementevaluator.h
cppfileiterationorder.cpp cppfileiterationorder.h
@@ -49,6 +49,7 @@ add_qtc_plugin(CppEditor
cppfollowsymbolundercursor.cpp cppfollowsymbolundercursor.h
cppfunctiondecldeflink.cpp cppfunctiondecldeflink.h
cppfunctionparamrenaminghandler.cpp cppfunctionparamrenaminghandler.h
+ cppheadersource.cpp cppheadersource.h
cpphighlighter.cpp cpphighlighter.h
cppincludehierarchy.cpp cppincludehierarchy.h
cppincludesfilter.cpp cppincludesfilter.h
@@ -121,7 +122,6 @@ extend_qtc_plugin(CppEditor
cppcodegen_test.cpp cppcodegen_test.h
cppcompletion_test.cpp cppcompletion_test.h
cppdoxygen_test.cpp cppdoxygen_test.h
- cppheadersource_test.cpp cppheadersource_test.h
cppincludehierarchy_test.cpp cppincludehierarchy_test.h
cpplocalsymbols_test.cpp cpplocalsymbols_test.h
cpplocatorfilter_test.cpp cpplocatorfilter_test.h