aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/cppeditor/CMakeLists.txt
diff options
context:
space:
mode:
authorCristian Adam <cristian.adam@qt.io>2022-04-21 14:10:09 +0200
committerCristian Adam <cristian.adam@qt.io>2022-04-29 07:16:53 +0000
commit88781a003ffd5f699f70b06d2d99325cf4e60c0f (patch)
tree2b4c888fbcdf57a870302d4d6e68cefef7e19a62 /src/plugins/cppeditor/CMakeLists.txt
parent58b0a5056c3afe922a2fe8570735da03fb9c3db5 (diff)
CMake: Qt Creator Static build support
This adds the build system feature that allows Qt Creator's libraries and plugins to be compiled statically. Fixes some symbol clashes when all plugins are linked into the same executable. Support for actually loading static plugins will be added in a separate commit. The feature is controlled by QTC_STATIC_BUILD which by default is OFF. Change-Id: I1fab7953c43e42dc75619e35660029ee067106df Reviewed-by: hjk <hjk@qt.io> Reviewed-by: Eike Ziller <eike.ziller@qt.io> Reviewed-by: <github-actions-qt-creator@cristianadam.eu> Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org>
Diffstat (limited to 'src/plugins/cppeditor/CMakeLists.txt')
-rw-r--r--src/plugins/cppeditor/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/src/plugins/cppeditor/CMakeLists.txt b/src/plugins/cppeditor/CMakeLists.txt
index a5b0f7ff53..7a4d9d6803 100644
--- a/src/plugins/cppeditor/CMakeLists.txt
+++ b/src/plugins/cppeditor/CMakeLists.txt
@@ -1,5 +1,4 @@
add_qtc_plugin(CppEditor
- DEFINES CPPEDITOR_LIBRARY
DEPENDS Qt5::Network Qt5::Xml
PUBLIC_DEPENDS CPlusPlus ClangSupport Qt5::Widgets
PLUGIN_DEPENDS Core ProjectExplorer TextEditor