aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/cppeditor/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Kandeler <christian.kandeler@qt.io>2022-04-25 13:37:58 +0200
committerChristian Kandeler <christian.kandeler@qt.io>2022-04-28 09:47:52 +0000
commitf2c267f3283ef70ad053b507b17513be068b2e6b (patch)
treef7dd540213b7042a6e51e83f6252d55f5fa248b4 /src/plugins/cppeditor/CMakeLists.txt
parent8e586dfa022232a82762503c896a0088429cd8c7 (diff)
ClangCodeModel: Remove libclang fallback for "follow symbol"
... and "switch between declaration/definition". It's either clangd or built-in code model now. Use the opportunity to dissolve the pointless FollowSymbolInterface class hierarchy, which introduced a confusing parallel inheritance chain. Change-Id: I792ad55656c5dd9f10c6b4db7c5c36cf7be45125 Reviewed-by: <github-actions-qt-creator@cristianadam.eu> Reviewed-by: David Schulz <david.schulz@qt.io>
Diffstat (limited to 'src/plugins/cppeditor/CMakeLists.txt')
-rw-r--r--src/plugins/cppeditor/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/src/plugins/cppeditor/CMakeLists.txt b/src/plugins/cppeditor/CMakeLists.txt
index 31f28cd13c..a5b0f7ff53 100644
--- a/src/plugins/cppeditor/CMakeLists.txt
+++ b/src/plugins/cppeditor/CMakeLists.txt
@@ -102,7 +102,6 @@ add_qtc_plugin(CppEditor
cursorineditor.h
doxygengenerator.cpp doxygengenerator.h
editordocumenthandle.cpp editordocumenthandle.h
- followsymbolinterface.h
functionutils.cpp functionutils.h
generatedcodemodelsupport.cpp generatedcodemodelsupport.h
headerpathfilter.cpp headerpathfilter.h