aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/cppeditor/CMakeLists.txt
diff options
context:
space:
mode:
authorEike Ziller <eike.ziller@qt.io>2019-05-22 11:06:04 +0200
committerEike Ziller <eike.ziller@qt.io>2019-05-22 15:06:48 +0000
commitfc8be0ccc65851a943ba36e0309dbc2680989423 (patch)
tree05bd99ce001cf316bc56c8c375a42eac8c08c09a /src/plugins/cppeditor/CMakeLists.txt
parentaa07bf6f70c90943ce25afbad0534a43cdd1f494 (diff)
CMake build: Fix compilation of tests
Some more explicit mocs needed on macOS/Clang Change-Id: I0d26f499c4abe70a3fd625752bb28f86a023cd36 Reviewed-by: Cristian Adam <cristian.adam@qt.io> Reviewed-by: Tobias Hunger <tobias.hunger@qt.io>
Diffstat (limited to 'src/plugins/cppeditor/CMakeLists.txt')
-rw-r--r--src/plugins/cppeditor/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/plugins/cppeditor/CMakeLists.txt b/src/plugins/cppeditor/CMakeLists.txt
index a921291f04..d38a153ce1 100644
--- a/src/plugins/cppeditor/CMakeLists.txt
+++ b/src/plugins/cppeditor/CMakeLists.txt
@@ -41,4 +41,6 @@ if (WITH_TESTS)
fileandtokenactions_test.cpp
followsymbol_switchmethoddecldef_test.cpp
)
+ set_explicit_moc(CppEditor cppdoxygen_test.h)
+ set_explicit_moc(CppEditor cppquickfix_test.h)
endif()