aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/cpptools/CMakeLists.txt
diff options
context:
space:
mode:
authorEike Ziller <eike.ziller@qt.io>2019-05-21 12:22:35 +0200
committerEike Ziller <eike.ziller@qt.io>2019-05-23 11:13:21 +0000
commit6fb9bf453f6f67af42649034af4ec5745e12d901 (patch)
treee848c277b7c2dac30fa0254051994e7c121ea5c3 /src/plugins/cpptools/CMakeLists.txt
parent9645687e539bd0ea286fb4136329458c3db3694e (diff)
CMake build: Add ability to disable building of individual plugins
Adds a cache entry "BUILD_PLUGIN_${NAME}", defaulting to ON which can be set to OFF to disable building of a plugin. Adds a extend_qtc_plugin function that should be used to add properties to a plugin after add_qtc_plugin, instead of the standard CMake functions target_... . The new function results in a no-op if the plugin was disabled. Change-Id: I57f6799620aea0aaa8b56acead4815ccced95911 Reviewed-by: Cristian Adam <cristian.adam@qt.io> Reviewed-by: Alessandro Portale <alessandro.portale@qt.io>
Diffstat (limited to 'src/plugins/cpptools/CMakeLists.txt')
-rw-r--r--src/plugins/cpptools/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/plugins/cpptools/CMakeLists.txt b/src/plugins/cpptools/CMakeLists.txt
index 52e6a7cbd42..e810c379f8c 100644
--- a/src/plugins/cpptools/CMakeLists.txt
+++ b/src/plugins/cpptools/CMakeLists.txt
@@ -112,8 +112,9 @@ add_qtc_plugin(CppTools
wrappablelineedit.cpp wrappablelineedit.h
)
-if (WITH_TESTS)
- target_sources(CppTools PRIVATE
+extend_qtc_plugin(CppTools
+ CONDITION WITH_TESTS
+ SOURCES
cppcodegen_test.cpp
cppcompletion_test.cpp
cppheadersource_test.cpp
@@ -127,5 +128,4 @@ if (WITH_TESTS)
modelmanagertesthelper.cpp modelmanagertesthelper.h
symbolsearcher_test.cpp
typehierarchybuilder_test.cpp
- )
-endif()
+)