aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/languageclient/CMakeLists.txt
diff options
context:
space:
mode:
authorCristian Adam <cristian.adam@qt.io>2020-02-25 20:02:38 +0100
committerAlessandro Portale <alessandro.portale@qt.io>2020-02-26 11:57:11 +0000
commit4e058a10b48cefa4841e9129d9bf7a99e05f3211 (patch)
tree9e02d7d39a4592934f65f16c8dcbe37f95f6f478 /src/plugins/languageclient/CMakeLists.txt
parent82b6de6db6fe2be3a2c178fb713309da84ca00b6 (diff)
CMake Build: Fix linking PythonPlugin in Debug mode with MinGW
PythonPlugin depends on LanguageClient, which has a private dependency on LanguageServerProtocol. This fixes this error: src/plugins/python/CMakeFiles/Python.dir/pythonrunconfiguration.cpp.obj: In function `int LanguageServerProtocol::JsonObject::typedValue<int>(QString const&) const': src/libs/languageserverprotocol/jsonobject.h:134: undefined reference to `__imp__ZN22LanguageServerProtocol13fromJsonValueIiEET_RK10QJsonValue' Change-Id: I7cacbf68a00ff9ff2a6ab9618bc6ec371247a0aa Reviewed-by: Alessandro Portale <alessandro.portale@qt.io>
Diffstat (limited to 'src/plugins/languageclient/CMakeLists.txt')
-rw-r--r--src/plugins/languageclient/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/plugins/languageclient/CMakeLists.txt b/src/plugins/languageclient/CMakeLists.txt
index d1910757db..abddb9cd96 100644
--- a/src/plugins/languageclient/CMakeLists.txt
+++ b/src/plugins/languageclient/CMakeLists.txt
@@ -1,5 +1,5 @@
add_qtc_plugin(LanguageClient
- DEPENDS LanguageServerProtocol Qt5::Core
+ PUBLIC_DEPENDS LanguageServerProtocol Qt5::Core
PLUGIN_DEPENDS ProjectExplorer Core TextEditor
SOURCES
client.cpp client.h