aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/modeleditor/CMakeLists.txt
diff options
context:
space:
mode:
authorCristian Adam <cristian.adam@gmail.com>2019-05-12 22:20:56 +0200
committerCristian Adam <cristian.adam@gmail.com>2019-05-17 13:33:28 +0000
commitd855b84c5df923394ace3bb91dab379f7e0daa34 (patch)
treee184ccdf5724151465a1653f9fc308af43293de8 /src/plugins/modeleditor/CMakeLists.txt
parentf872a95fddd2690bb6953a17e48935c1b12d83d9 (diff)
Qt Creator CMake port
Based on Tobias Hunger's work from a few months ago. The CMake configuration needs libclang and Qt paths specified as CMAKE_PREFIX_PATH. Auto tests are run with "ctest". At the moment the pass rate is 87%. Change-Id: Iba98e39bf22077d52706dce6c85986be67a6eab0 Reviewed-by: Alessandro Portale <alessandro.portale@qt.io> Reviewed-by: Tobias Hunger <tobias.hunger@qt.io> Reviewed-by: Eike Ziller <eike.ziller@qt.io>
Diffstat (limited to 'src/plugins/modeleditor/CMakeLists.txt')
-rw-r--r--src/plugins/modeleditor/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/src/plugins/modeleditor/CMakeLists.txt b/src/plugins/modeleditor/CMakeLists.txt
new file mode 100644
index 0000000000..69ff243b5c
--- /dev/null
+++ b/src/plugins/modeleditor/CMakeLists.txt
@@ -0,0 +1,36 @@
+add_qtc_plugin(ModelEditor
+ DEFINES MODELEDITOR_LIBRARY
+ DEPENDS Modeling Qt5::Core Qt5::Gui Qt5::Widgets
+ PLUGIN_DEPENDS Core CppTools ProjectExplorer
+ SOURCES
+ actionhandler.cpp actionhandler.h
+ classviewcontroller.cpp classviewcontroller.h
+ componentviewcontroller.cpp componentviewcontroller.h
+ diagramsviewmanager.cpp diagramsviewmanager.h
+ dragtool.cpp dragtool.h
+ editordiagramview.cpp editordiagramview.h
+ elementtasks.cpp elementtasks.h
+ extdocumentcontroller.cpp extdocumentcontroller.h
+ extpropertiesmview.cpp extpropertiesmview.h
+ jsextension.cpp jsextension.h
+ modeldocument.cpp modeldocument.h
+ modeleditor.cpp modeleditor.h
+ modeleditor_constants.h
+ modeleditor_global.h
+ modeleditor_plugin.cpp modeleditor_plugin.h
+ modeleditorfactory.cpp modeleditorfactory.h
+ modelindexer.cpp modelindexer.h
+ modelsmanager.cpp modelsmanager.h
+ modelutilities.cpp modelutilities.h
+ openelementvisitor.cpp openelementvisitor.h
+ packageviewcontroller.cpp packageviewcontroller.h
+ pxnodecontroller.cpp pxnodecontroller.h
+ pxnodeutilities.cpp pxnodeutilities.h
+ resources/modeleditor.qrc
+ settingscontroller.cpp settingscontroller.h
+ uicontroller.cpp uicontroller.h
+ EXPLICIT_MOC
+ actionhandler.h
+ modeleditor.h
+ modeleditorfactory.h
+)