aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/python/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Schulz <david.schulz@qt.io>2019-07-15 12:50:29 +0200
committerDavid Schulz <david.schulz@qt.io>2019-07-17 06:21:23 +0000
commit3213e12ce7411efd05a544645aaa1ecd74e533a2 (patch)
treeae7187904453f530d4660832ff834371905cefaf /src/plugins/python/CMakeLists.txt
parent2778a5adab13a16f4a6b3cda0980fa3b4f2b3a5e (diff)
rename PythonEditor plugin to Python
The plugin does not only contain a pure editor, but all kind of support for a programming language like project and run support. Change-Id: I1251367c8db2e7a54986415ffc5b860cb210de3c Reviewed-by: Christian Stenger <christian.stenger@qt.io>
Diffstat (limited to 'src/plugins/python/CMakeLists.txt')
-rw-r--r--src/plugins/python/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/plugins/python/CMakeLists.txt b/src/plugins/python/CMakeLists.txt
new file mode 100644
index 00000000000..4036e919b38
--- /dev/null
+++ b/src/plugins/python/CMakeLists.txt
@@ -0,0 +1,11 @@
+add_qtc_plugin(Python
+ PLUGIN_DEPENDS Core QtSupport ProjectExplorer TextEditor
+ SOURCES
+ pythoneditor.cpp pythoneditor.h
+ pythonconstants.h
+ pythonplugin.cpp pythonplugin.h
+ pythonformattoken.h
+ pythonhighlighter.cpp pythonhighlighter.h
+ pythonindenter.cpp pythonindenter.h
+ pythonscanner.cpp pythonscanner.h
+)