aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/python/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Schulz <david.schulz@qt.io>2019-07-05 09:40:31 +0200
committerDavid Schulz <david.schulz@qt.io>2019-07-30 07:41:30 +0000
commita99e5af1da276ddca391fb56a1a9a5334794f298 (patch)
tree4bf3480ff509838fd739a844a64df9b639adb2ab /src/plugins/python/CMakeLists.txt
parent1fb41647ebfef47e5d83e047e46f9caec16026a6 (diff)
Python: make interpreter configurable
Add settings page to setup python interpreter and use a combo box in the run configuration to switch between those configured interpreter. Change-Id: I51014b785ea822ee138d39c788149f1d22901e55 Reviewed-by: Christian Stenger <christian.stenger@qt.io> Reviewed-by: David Schulz <david.schulz@qt.io>
Diffstat (limited to 'src/plugins/python/CMakeLists.txt')
-rw-r--r--src/plugins/python/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/plugins/python/CMakeLists.txt b/src/plugins/python/CMakeLists.txt
index 4036e919b38..7dd1f2fab5d 100644
--- a/src/plugins/python/CMakeLists.txt
+++ b/src/plugins/python/CMakeLists.txt
@@ -1,11 +1,13 @@
add_qtc_plugin(Python
PLUGIN_DEPENDS Core QtSupport ProjectExplorer TextEditor
SOURCES
+ python.qrc
pythoneditor.cpp pythoneditor.h
pythonconstants.h
pythonplugin.cpp pythonplugin.h
pythonformattoken.h
pythonhighlighter.cpp pythonhighlighter.h
pythonindenter.cpp pythonindenter.h
+ pythonsettings.cpp pythonsettings.h
pythonscanner.cpp pythonscanner.h
)