aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/python/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Schulz <david.schulz@qt.io>2019-07-24 10:19:19 +0200
committerDavid Schulz <david.schulz@qt.io>2019-09-26 07:35:11 +0000
commite232dfe2e67f5513d841716130bb5fe4ac720028 (patch)
treed08f507a4e5804243b5afa560fa80c9fa09317ef /src/plugins/python/CMakeLists.txt
parentb0f796e4e397cce65dd05ac92c360aef6eaeb8b2 (diff)
Python: Check for Python language server after document was opened
Show an info bar entry with a one click solution to setup a language server if the python which is most likely to be used for this file has an installed language server. Change-Id: Ia52bb043b543699527740951f68cc6be546833df Reviewed-by: Christian Stenger <christian.stenger@qt.io>
Diffstat (limited to 'src/plugins/python/CMakeLists.txt')
-rw-r--r--src/plugins/python/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/plugins/python/CMakeLists.txt b/src/plugins/python/CMakeLists.txt
index 7ecc160f3a9..27f45669f7f 100644
--- a/src/plugins/python/CMakeLists.txt
+++ b/src/plugins/python/CMakeLists.txt
@@ -1,5 +1,5 @@
add_qtc_plugin(Python
- PLUGIN_DEPENDS Core ProjectExplorer TextEditor
+ PLUGIN_DEPENDS Core LanguageClient ProjectExplorer TextEditor
SOURCES
python.qrc
pythoneditor.cpp pythoneditor.h