aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/qmldesigner/CMakeLists.txt
diff options
context:
space:
mode:
authorThomas Hartmann <thomas.hartmann@qt.io>2023-08-29 12:16:26 +0200
committerThomas Hartmann <thomas.hartmann@qt.io>2023-08-29 16:03:51 +0000
commit3e0ae7951d6dd54d1fd5d5cef50230059e0ca67e (patch)
treed147c0564d33f5ec44afade0c6b46f9146416bd9 /src/plugins/qmldesigner/CMakeLists.txt
parent02119439091c2795bc729acaedde11f373ae91ae (diff)
QmlDesigner: Add PropertyTreeModel
This model represents all properties in the document in a tree model. PropertyListProxyModel allows to flatten a level into a list model. PropertyTreeModelDelegate exposed a single item to a combobox. Change-Id: I9b56f1ecc9aa57777356bc795b5a15b17559ae24 Reviewed-by: Qt CI Patch Build Bot <ci_patchbuild_bot@qt.io> Reviewed-by: Henning Gründl <henning.gruendl@qt.io> Reviewed-by: <github-actions-qt-creator@cristianadam.eu>
Diffstat (limited to 'src/plugins/qmldesigner/CMakeLists.txt')
-rw-r--r--src/plugins/qmldesigner/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/plugins/qmldesigner/CMakeLists.txt b/src/plugins/qmldesigner/CMakeLists.txt
index 689c6bce9b0..7f94c8ff256 100644
--- a/src/plugins/qmldesigner/CMakeLists.txt
+++ b/src/plugins/qmldesigner/CMakeLists.txt
@@ -13,7 +13,7 @@ add_compile_options("$<$<COMPILE_LANG_AND_ID:CXX,GNU>:-Wno-error=maybe-uninitial
add_qtc_library(QmlDesignerUtils STATIC
DEPENDS
- Qt::Gui Utils Qt::QmlPrivate
+ Qt::Gui Utils Qt::QmlPrivate Core
DEFINES QMLDESIGNERUTILS_LIBRARY
PUBLIC_DEFINES $<$<BOOL:${QTC_STATIC_BUILD}>:QMLDESIGNER_STATIC_LIBRARY>
@@ -486,6 +486,7 @@ add_qtc_plugin(QmlDesigner
EXPLICIT_MOC
components/propertyeditor/propertyeditorvalue.h
components/connectioneditor/connectionviewwidget.h
+ qmldesignerplugin.h
EXTRA_TRANSLATIONS
"${PROJECT_SOURCE_DIR}/share/qtcreator/qmldesigner"
PROPERTIES
@@ -946,6 +947,7 @@ extend_qtc_plugin(QmlDesigner
delegates.cpp delegates.h
dynamicpropertiesmodel.cpp dynamicpropertiesmodel.h
selectiondynamicpropertiesproxymodel.cpp selectiondynamicpropertiesproxymodel.h
+ propertytreemodel.cpp propertytreemodel.h
)
extend_qtc_plugin(QmlDesigner