aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/qmldesigner/CMakeLists.txt
diff options
context:
space:
mode:
authorMarco Bubke <marco.bubke@qt.io>2023-05-11 20:07:48 +0200
committerMarco Bubke <marco.bubke@qt.io>2023-05-31 08:05:59 +0000
commit504d24db30f31db9a18ad57d83f38fa186775d38 (patch)
tree90dc6c2de2246a3f978eced51a7d496921dd1b8a /src/plugins/qmldesigner/CMakeLists.txt
parentbf7f07605b7c1d6c292527f9f6382c5558a76577 (diff)
QmlDesigner: Model resource management
The model is now deleting and changing the dependencies by itself. That has the advantage of consistency. So if a node is now removed all the dependecies will be deleted changing in the same way. Task-number: QDS-9766 Change-Id: I1edf9ce172e51b9f52b62612ed2bb7386bf5b221 Reviewed-by: Thomas Hartmann <thomas.hartmann@qt.io> Reviewed-by: <github-actions-qt-creator@cristianadam.eu>
Diffstat (limited to 'src/plugins/qmldesigner/CMakeLists.txt')
-rw-r--r--src/plugins/qmldesigner/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/plugins/qmldesigner/CMakeLists.txt b/src/plugins/qmldesigner/CMakeLists.txt
index 340cbd77a1a..94140aa0217 100644
--- a/src/plugins/qmldesigner/CMakeLists.txt
+++ b/src/plugins/qmldesigner/CMakeLists.txt
@@ -342,6 +342,8 @@ extend_qtc_library(QmlDesignerCore
modelnodepositionrecalculator.h
modelnodepositionstorage.cpp
modelresourcemanagementinterface.h
+ modelresourcemanagementfwd.h
+ modelresourcemanagement.cpp modelresourcemanagement.h
modeltotextmerger.cpp
modeltotextmerger.h
modelutils.cpp