aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/qmldesigner/CMakeLists.txt
diff options
context:
space:
mode:
authorTim Jenssen <tim.jenssen@qt.io>2023-07-20 22:41:50 +0200
committerTim Jenssen <tim.jenssen@qt.io>2023-07-21 10:20:45 +0000
commit7df557c0babb11f0c94ca118cfdec7cf8c142f71 (patch)
treefa8bf8c56c044438ebe11254e4d62230fcdebb59 /src/plugins/qmldesigner/CMakeLists.txt
parent012f926f7c28e34eadfe93f1365d63f0a11b4c80 (diff)
parent655ec9d94880cb7f3c5ff3bf4917705f7629b0d3 (diff)
Merge remote-tracking branch 'origin/qds/dev'
Conflicts: tests/unit/tests/printers/gtest-creator-printing.cpp Change-Id: I5f791161ca1a2966e98a3ca55bc60e5bcbb8f58f
Diffstat (limited to 'src/plugins/qmldesigner/CMakeLists.txt')
-rw-r--r--src/plugins/qmldesigner/CMakeLists.txt42
1 files changed, 24 insertions, 18 deletions
diff --git a/src/plugins/qmldesigner/CMakeLists.txt b/src/plugins/qmldesigner/CMakeLists.txt
index b6d9f10bfb..405ad5c00a 100644
--- a/src/plugins/qmldesigner/CMakeLists.txt
+++ b/src/plugins/qmldesigner/CMakeLists.txt
@@ -82,7 +82,6 @@ if(TARGET QmlDesignerCore)
add_feature_info("ProjectStorage" ${USE_PROJECTSTORAGE} "")
endif()
-
extend_qtc_library(QmlDesignerCore
CONDITION ENABLE_COMPILE_WARNING_AS_ERROR
PROPERTIES COMPILE_WARNING_AS_ERROR ON
@@ -186,23 +185,40 @@ extend_qtc_library(QmlDesignerCore
extend_qtc_library(QmlDesignerCore
SOURCES_PREFIX ${CMAKE_CURRENT_LIST_DIR}/designercore/include
SOURCES
- abstractproperty.h
abstractview.h
+ basetexteditmodifier.h
+ bytearraymodifier.h
+ componenttextmodifier.h
+ forwardview.h
+ itemlibraryinfo.h
+ metainforeader.h
+ model.h
+ nodehints.h
+ plaintexteditmodifier.h
+ nodeinstanceview.h
+ propertyparser.h
+ rewriterview.h
+ subcomponentmanager.h
+ textmodifier.h
+)
+
+extend_qtc_library(QmlDesignerCore
+ SOURCES_PROPERTIES SKIP_AUTOGEN ON
+ SOURCES_PREFIX ${CMAKE_CURRENT_LIST_DIR}/designercore/include
+ SOURCES
+ abstractproperty.h
anchorline.h
annotation.h
asynchronousexplicitimagecache.h
asynchronousimagecache.h
auxiliarydata.h
auxiliarydataproperties.h
- basetexteditmodifier.h
bindingproperty.h
- componenttextmodifier.h
customnotifications.h
documentmessage.h
enumerationmetainfo.h
exception.h
externaldependenciesinterface.h
- forwardview.h
imagecacheauxiliarydata.h
import.h
invalidargumentexception.h
@@ -214,33 +230,26 @@ extend_qtc_library(QmlDesignerCore
invalidqmlsourceexception.h
invalidreparentingexception.h
invalidslideindexexception.h
- itemlibraryinfo.h
mathutils.h
metainfo.h
- metainforeader.h
- model.h
modelfwd.h
modelmerger.h
modelnode.h
modelnodepositionstorage.h
nodeabstractproperty.h
- nodehints.h
nodeinstance.h
- nodeinstanceview.h
nodelistproperty.h
nodemetainfo.h
nodeproperty.h
notimplementedexception.h
- plaintexteditmodifier.h
propertycontainer.h
propertymetainfo.h
propertynode.h
- propertyparser.h
qmlanchors.h
qmlchangeset.h
qmlconnections.h
- qmldesignercorelib_global.h
qmldesignercorelib_exports.h
+ qmldesignercorelib_global.h
qmlitemnode.h
qmlmodelnodefacade.h
qmlobjectnode.h
@@ -248,14 +257,11 @@ extend_qtc_library(QmlDesignerCore
qmltimeline.h
qmltimelinekeyframegroup.h
removebasestateexception.h
- rewriterview.h
rewritingexception.h
signalhandlerproperty.h
stringutils.h
stylesheetmerger.h
- subcomponentmanager.h
synchronousimagecache.h
- textmodifier.h
variantproperty.h
)
@@ -382,7 +388,7 @@ extend_qtc_library(QmlDesignerCore
extend_qtc_library(QmlDesignerCore
SOURCES_PREFIX designercore/projectstorage
PUBLIC_INCLUDES designercore/projectstorage
- SOURCES_PROPERTIES SKIP_AUTOMOC ON
+ SOURCES_PROPERTIES SKIP_AUTOGEN ON
SOURCES
commontypecache.h
directorypathcompressor.h
@@ -407,7 +413,7 @@ extend_qtc_library(QmlDesignerCore
projectstorage.cpp projectstorage.h
sourcepath.h
sourcepathcache.h
- sourcepathcache.h
+ sourcepathcacheinterface.h
sourcepathcachetypes.h
sourcepathview.h
storagecache.h