aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/qmldesigner/CMakeLists.txt
diff options
context:
space:
mode:
authorMiikka Heikkinen <miikka.heikkinen@qt.io>2020-09-10 16:02:31 +0300
committerMiikka Heikkinen <miikka.heikkinen@qt.io>2020-09-16 07:00:06 +0000
commit90d9cb36f3ae756fe08ddfbf74756ada62df6918 (patch)
tree9b277ed53e957412923756eadb3c7530a44b23f9 /src/plugins/qmldesigner/CMakeLists.txt
parentf849bd110552571f985ae691677d7c44b8affd82 (diff)
QmlDesigner: Add navigator preview tooltip for materials
Request 3D preview image for material instances from puppet to show on tooltip. Support for effect previews is also done, but handler for it is not registered, as effects cannot be shared between windows due to issue QTBUG-86616. Also refactored the preview image support out of navigator to make it more accessible by other components. Change-Id: Ie08ba218f929660c2e43d39578997a5a1a883efd Reviewed-by: Thomas Hartmann <thomas.hartmann@qt.io>
Diffstat (limited to 'src/plugins/qmldesigner/CMakeLists.txt')
-rw-r--r--src/plugins/qmldesigner/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/plugins/qmldesigner/CMakeLists.txt b/src/plugins/qmldesigner/CMakeLists.txt
index 6a8ac1924c..cf5ee686bf 100644
--- a/src/plugins/qmldesigner/CMakeLists.txt
+++ b/src/plugins/qmldesigner/CMakeLists.txt
@@ -166,6 +166,7 @@ extend_qtc_plugin(QmlDesigner
puppettocreatorcommand.cpp puppettocreatorcommand.h
inputeventcommand.cpp inputeventcommand.h
view3dactioncommand.cpp view3dactioncommand.h
+ requestmodelnodepreviewimagecommand.cpp requestmodelnodepreviewimagecommand.h
)
extend_qtc_plugin(QmlDesigner