aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/qmldesigner/CMakeLists.txt
diff options
context:
space:
mode:
authorTim Jenssen <tim.jenssen@qt.io>2023-08-15 20:55:38 +0200
committerTim Jenssen <tim.jenssen@qt.io>2023-08-15 18:57:48 +0000
commit91a931dd218fe18ab77bd2b17127c3a52d5f4db1 (patch)
tree8c40f72aaae3dc4c032a6f3403c5cae0196e89d6 /src/plugins/qmldesigner/CMakeLists.txt
parent0f7462ad24fbeac755b3cc893138f9cbf5be1f99 (diff)
QmlDesigner: build it only if Qt is GREATER_EQUAL 6.4.3
Change-Id: Iccd05a7d4f4ace47fd9398bdc78584e3919ec595 Reviewed-by: Tim Jenssen <tim.jenssen@qt.io>
Diffstat (limited to 'src/plugins/qmldesigner/CMakeLists.txt')
-rw-r--r--src/plugins/qmldesigner/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/plugins/qmldesigner/CMakeLists.txt b/src/plugins/qmldesigner/CMakeLists.txt
index 409bf10c3fd..2320b4d76fd 100644
--- a/src/plugins/qmldesigner/CMakeLists.txt
+++ b/src/plugins/qmldesigner/CMakeLists.txt
@@ -37,7 +37,7 @@ extend_qtc_library(QmlDesignerUtils
)
add_qtc_library(QmlDesignerCore STATIC
- CONDITION Qt6_VERSION VERSION_GREATER_EQUAL 6.4.3 AND TARGET QmlDesignerBase AND TARGET Qt6::QmlPrivate AND TARGET Qt6::QmlDomPrivate AND TARGET Qt6::QmlCompilerPrivate
+ CONDITION TARGET QmlDesignerBase AND TARGET Qt6::QmlPrivate AND TARGET Qt6::QmlDomPrivate AND TARGET Qt6::QmlCompilerPrivate
EXCLUDE_FROM_INSTALL
PROPERTIES SKIP_AUTOUIC ON
DEPENDS
@@ -428,7 +428,7 @@ extend_qtc_library(QmlDesignerCore
add_qtc_plugin(QmlDesigner
PLUGIN_RECOMMENDS QmlPreview
- CONDITION Qt6_VERSION VERSION_GREATER_EQUAL 6.4.3 AND TARGET QmlDesignerCore AND TARGET Qt::QuickWidgets AND TARGET Qt::Svg
+ CONDITION TARGET QmlDesignerCore AND TARGET Qt::QuickWidgets AND TARGET Qt::Svg
PLUGIN_DEPENDS
Core ProjectExplorer QmlDesignerBase QmlJSEditor QmakeProjectManager QmlProjectManager
QtSupport