aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/qmldesigner/CMakeLists.txt
diff options
context:
space:
mode:
authorMarco Bubke <marco.bubke@qt.io>2023-09-14 17:34:29 +0200
committerMarco Bubke <marco.bubke@qt.io>2023-10-04 10:28:56 +0000
commit975a282130a846f55ef204436b96c01ddf17eab0 (patch)
treef196fd792a5b6fb205021a0db5271bd040a037a3 /src/plugins/qmldesigner/CMakeLists.txt
parentebe1c889b79c7e6abd93adc8fe2f9c155d82c9fa (diff)
QmlDesigner: Ensure that indirect imports are deleted too
If we import an indirect import can be added too. So if we remove that import we have to remove the related indirect imports too. Change-Id: I4cb09fdc8986c473db2a8194766778956bc7069a Reviewed-by: Tim Jenssen <tim.jenssen@qt.io> Reviewed-by: Qt CI Patch Build Bot <ci_patchbuild_bot@qt.io>
Diffstat (limited to 'src/plugins/qmldesigner/CMakeLists.txt')
-rw-r--r--src/plugins/qmldesigner/CMakeLists.txt16
1 files changed, 8 insertions, 8 deletions
diff --git a/src/plugins/qmldesigner/CMakeLists.txt b/src/plugins/qmldesigner/CMakeLists.txt
index 80273e863b..0d7c39784c 100644
--- a/src/plugins/qmldesigner/CMakeLists.txt
+++ b/src/plugins/qmldesigner/CMakeLists.txt
@@ -11,6 +11,10 @@ endif()
add_compile_options("$<$<COMPILE_LANG_AND_ID:CXX,Clang>:-Wno-error=maybe-uninitialized>")
add_compile_options("$<$<COMPILE_LANG_AND_ID:CXX,GNU>:-Wno-error=maybe-uninitialized>")
+env_with_default("QDS_USE_PROJECTSTORAGE" ENV_QDS_USE_PROJECTSTORAGE OFF)
+option(USE_PROJECTSTORAGE "Use ProjectStorage" ${ENV_QDS_USE_PROJECTSTORAGE})
+add_feature_info("ProjectStorage" ${USE_PROJECTSTORAGE} "")
+
add_qtc_library(QmlDesignerUtils STATIC
DEPENDS
Qt::Gui Utils Qt::QmlPrivate Core
@@ -64,7 +68,10 @@ add_qtc_library(QmlDesignerCore STATIC
QmlDesignerUtils
TextEditor
Sqlite
- DEFINES QMLDESIGNERCORE_LIBRARY QMLDESIGNERUTILS_LIBRARY
+ DEFINES
+ QMLDESIGNERCORE_LIBRARY
+ QMLDESIGNERUTILS_LIBRARY
+ $<$<BOOL:${USE_PROJECTSTORAGE}>:QDS_USE_PROJECTSTORAGE>
INCLUDES
${CMAKE_CURRENT_LIST_DIR}
PUBLIC_INCLUDES
@@ -76,13 +83,6 @@ add_qtc_library(QmlDesignerCore STATIC
rewritertransaction.h
)
-
-if(TARGET QmlDesignerCore)
- env_with_default("QDS_USE_PROJECTSTORAGE" ENV_QDS_USE_PROJECTSTORAGE OFF)
- option(USE_PROJECTSTORAGE "Use ProjectStorage" ${ENV_QDS_USE_PROJECTSTORAGE})
- add_feature_info("ProjectStorage" ${USE_PROJECTSTORAGE} "")
-endif()
-
extend_qtc_library(QmlDesignerCore
CONDITION ENABLE_COMPILE_WARNING_AS_ERROR
PROPERTIES COMPILE_WARNING_AS_ERROR ON