aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/qmldesigner/CMakeLists.txt
diff options
context:
space:
mode:
authorMarco Bubke <marco.bubke@qt.io>2023-10-14 15:56:03 +0200
committerTim Jenssen <tim.jenssen@qt.io>2023-10-17 11:55:03 +0000
commitad12bbb6698a6c00ed127f79a0078f52b1e7ce7d (patch)
tree10bc3ca87b822387a0763defa7f25824f75d043a /src/plugins/qmldesigner/CMakeLists.txt
parent11bf705e26bec1db1f33304d2cdbd00559b91b9c (diff)
QmlDesigner: Add object trace
'N' and 'D' phases are not supported by Perfetto. So I mapped it to async events. This patch is improving the interface for arguments too. Now you can select the type for you arguments. So the name can be a string_view but the arguments can be a string. The variadic template arguments are used to prevent any conversion code which could not be optimized out for an empty function. Change-Id: I1ad1927b5e3b63607a21df1351b1f5cfba50159c Reviewed-by: Tim Jenssen <tim.jenssen@qt.io> Reviewed-by: Qt CI Patch Build Bot <ci_patchbuild_bot@qt.io> Reviewed-by: <github-actions-qt-creator@cristianadam.eu>
Diffstat (limited to 'src/plugins/qmldesigner/CMakeLists.txt')
-rw-r--r--src/plugins/qmldesigner/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/src/plugins/qmldesigner/CMakeLists.txt b/src/plugins/qmldesigner/CMakeLists.txt
index e92dc29942..275e75a8cf 100644
--- a/src/plugins/qmldesigner/CMakeLists.txt
+++ b/src/plugins/qmldesigner/CMakeLists.txt
@@ -23,6 +23,11 @@ env_with_default("QTC_ENABLE_IMAGE_CACHE_TRACING" ENV_QTC_ENABLE_IMAGE_CACHE_TRA
option(ENABLE_IMAGE_CACHE_TRACING "Enable image cache tracing" ${ENV_QTC_ENABLE_IMAGE_CACHE_TRACING})
add_feature_info("Image cache tracing" ${ENABLE_IMAGE_CACHE_TRACING} "")
+env_with_default("QTC_ENABLE_MODEL_TRACING" ENV_QTC_ENABLE_MODEL_TRACING OFF)
+option(ENABLE_MODEL_TRACING "Enable model tracing" ${ENV_QTC_ENABLE_MODEL_TRACING})
+add_feature_info("Model tracing" ${ENABLE_MODEL_TRACING} "")
+
+
add_qtc_library(QmlDesignerUtils STATIC
DEPENDS
@@ -96,8 +101,10 @@ extend_qtc_library(QmlDesignerCore
CONDITION TARGET Nanotrace
DEPENDS Nanotrace
DEFINES
+ ENABLE_QMLDESIGNER_TRACING
$<$<BOOL:${ENABLE_PROJECT_STORAGE_TRACING}>:ENABLE_PROJECT_STORAGE_TRACING>
$<$<BOOL:${ENABLE_IMAGE_CACHE_TRACING}>:ENABLE_IMAGE_CACHE_TRACING>
+ $<$<BOOL:${ENABLE_MODEL_TRACING}>:ENABLE_MODEL_TRACING>
)
extend_qtc_library(QmlDesignerCore
@@ -202,6 +209,12 @@ extend_qtc_library(QmlDesignerCore
)
extend_qtc_library(QmlDesignerCore
+ SOURCES_PREFIX ${CMAKE_CURRENT_LIST_DIR}/designercore/tracing
+ SOURCES
+ qmldesignertracing.cpp qmldesignertracing.h
+)
+
+extend_qtc_library(QmlDesignerCore
SOURCES_PREFIX ${CMAKE_CURRENT_LIST_DIR}/designercore/include
SOURCES
abstractview.h