aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/qmldesigner/CMakeLists.txt
diff options
context:
space:
mode:
authorMarco Bubke <marco.bubke@qt.io>2023-10-11 20:20:59 +0200
committerMarco Bubke <marco.bubke@qt.io>2023-10-12 11:14:42 +0000
commitc081c96bf0b99bc0c25943956a64014df65e7514 (patch)
tree06d92ec9d4b881f0b01f9ccf3ea11500801d8471 /src/plugins/qmldesigner/CMakeLists.txt
parent14476ee6062e17e4160714d53e55a5fcb8e95a8d (diff)
QmlDesigner: Add tracing to project storage
The tracing is by default disabled for the project storage category. So there is no overhead because the tracer instance is a empty class in that case. Change-Id: I7d3e91527871a946cadbbad2e11f0b2ab2825c59 Reviewed-by: Tim Jenssen <tim.jenssen@qt.io> Reviewed-by: <github-actions-qt-creator@cristianadam.eu> Reviewed-by: Qt CI Patch Build Bot <ci_patchbuild_bot@qt.io>
Diffstat (limited to 'src/plugins/qmldesigner/CMakeLists.txt')
-rw-r--r--src/plugins/qmldesigner/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/plugins/qmldesigner/CMakeLists.txt b/src/plugins/qmldesigner/CMakeLists.txt
index 5b62032338..6e8df88078 100644
--- a/src/plugins/qmldesigner/CMakeLists.txt
+++ b/src/plugins/qmldesigner/CMakeLists.txt
@@ -15,6 +15,11 @@ env_with_default("QDS_USE_PROJECTSTORAGE" ENV_QDS_USE_PROJECTSTORAGE OFF)
option(USE_PROJECTSTORAGE "Use ProjectStorage" ${ENV_QDS_USE_PROJECTSTORAGE})
add_feature_info("ProjectStorage" ${USE_PROJECTSTORAGE} "")
+env_with_default("QTC_ENABLE_PROJECT_STORAGE_TRACING" ENV_QTC_ENABLE_PROJECT_STORAGE_TRACING OFF)
+option(ENABLE_PROJECT_STORAGE_TRACING "Enable sqlite tarcing" ${ENV_QTC_ENABLE_PROJECT_STORAGE_TRACING})
+add_feature_info("Sqlite tracing" ${ENABLE_PROJECT_STORAGE_TRACING} "")
+
+
add_qtc_library(QmlDesignerUtils STATIC
DEPENDS
Qt::Gui Utils Qt::QmlPrivate Core
@@ -84,6 +89,13 @@ add_qtc_library(QmlDesignerCore STATIC
)
extend_qtc_library(QmlDesignerCore
+ CONDITION TARGET Nanotrace
+ DEPENDS Nanotrace
+ DEFINES
+ $<$<BOOL:${ENABLE_PROJECT_STORAGE_TRACING}>:ENABLE_PROJECT_STORAGE_TRACING>
+)
+
+extend_qtc_library(QmlDesignerCore
CONDITION ENABLE_COMPILE_WARNING_AS_ERROR
PROPERTIES COMPILE_WARNING_AS_ERROR ON
)