aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/qmldesigner/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael BrĂ¼ning <michael.bruning@qt.io>2020-05-07 16:43:39 +0200
committerThomas Hartmann <thomas.hartmann@qt.io>2020-05-27 18:26:12 +0000
commitde8eb93637d31e474fdada8ca8199b35841a7f7a (patch)
treeeb5d9775a9ee67c5831e3eec6d691eb63c996be3 /src/plugins/qmldesigner/CMakeLists.txt
parent5b0040185085704ea284cc7fdb6a95603caca203 (diff)
Add stylesheet merger
Adds classes to merge a template qml file and a qml stylesheet that have been exported from other design tools into a resulting qml file that can be used for further processing in Qt Design Studio. Current issues: * Sometimes it makes sense to define width and height if an anchor is present, but most of the time not. * Actually if the hierachy was defined (e.g. Text item not child of background) most likely the anchors should be ignored. But this would be just a "dirty" heuristic. I suggest to let the template decide. If the template has anchors those have "precedence". It is always possible to define templates without anchors. Task-number: QDS-2071 Change-Id: I9159514a8e884b7ffc31897aef4551b5efbbcb87 Reviewed-by: Thomas Hartmann <thomas.hartmann@qt.io>
Diffstat (limited to 'src/plugins/qmldesigner/CMakeLists.txt')
-rw-r--r--src/plugins/qmldesigner/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/plugins/qmldesigner/CMakeLists.txt b/src/plugins/qmldesigner/CMakeLists.txt
index 53a3e4de84..f9a6dc94cb 100644
--- a/src/plugins/qmldesigner/CMakeLists.txt
+++ b/src/plugins/qmldesigner/CMakeLists.txt
@@ -457,6 +457,7 @@ extend_qtc_plugin(QmlDesigner
include/rewriterview.h
include/rewritingexception.h
include/signalhandlerproperty.h
+ include/stylesheetmerger.h
include/subcomponentmanager.h
include/textmodifier.h
include/variantproperty.h
@@ -530,6 +531,7 @@ extend_qtc_plugin(QmlDesigner
model/rewriteactioncompressor.cpp model/rewriteactioncompressor.h
model/rewriterview.cpp
model/signalhandlerproperty.cpp
+ model/stylesheetmerger.cpp
model/textmodifier.cpp
model/texttomodelmerger.cpp model/texttomodelmerger.h
model/variantproperty.cpp