aboutsummaryrefslogtreecommitdiffstats
path: root/share/qtcreator/templates/wizards/qtcreatorplugin/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'share/qtcreator/templates/wizards/qtcreatorplugin/CMakeLists.txt')
-rw-r--r--share/qtcreator/templates/wizards/qtcreatorplugin/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/share/qtcreator/templates/wizards/qtcreatorplugin/CMakeLists.txt b/share/qtcreator/templates/wizards/qtcreatorplugin/CMakeLists.txt
new file mode 100644
index 0000000000..214dcfc221
--- /dev/null
+++ b/share/qtcreator/templates/wizards/qtcreatorplugin/CMakeLists.txt
@@ -0,0 +1,32 @@
+cmake_minimum_required(VERSION 3.9)
+
+# Remove when sharing with others.
+list(APPEND CMAKE_PREFIX_PATH "%{QtCreatorBuild}")
+
+project(%{PluginName})
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+set(CMAKE_CXX_STANDARD 17)
+
+find_package(QtCreator COMPONENTS Core REQUIRED)
+find_package(QT NAMES Qt6 Qt5 COMPONENTS Widgets REQUIRED)
+set(QtX Qt${QT_VERSION_MAJOR})
+
+add_qtc_plugin(%{PluginName}
+ PLUGIN_DEPENDS
+ QtCreator::Core
+ DEPENDS
+ ${QtX}::Widgets
+ QtCreator::ExtensionSystem
+ QtCreator::Utils
+ SOURCES
+ .github/workflows/build_cmake.yml
+ .github/workflows/README.md
+ README.md
+ %{SrcFileName}
+ %{HdrFileName}
+ %{GlobalHdrFileName}
+ %{ConstantsHdrFileName}
+)