aboutsummaryrefslogtreecommitdiffstats
path: root/src/libs/glsl/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/libs/glsl/CMakeLists.txt')
-rw-r--r--src/libs/glsl/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/src/libs/glsl/CMakeLists.txt b/src/libs/glsl/CMakeLists.txt
new file mode 100644
index 0000000000..e5fcb3692b
--- /dev/null
+++ b/src/libs/glsl/CMakeLists.txt
@@ -0,0 +1,19 @@
+add_qtc_library(GLSL
+ DEPENDS Qt5::Core
+ SOURCES
+ glsl.h
+ glslast.cpp glslast.h
+ glslastdump.cpp glslastdump.h
+ glslastvisitor.cpp glslastvisitor.h
+ glslengine.cpp glslengine.h
+ glslkeywords.cpp
+ glsllexer.cpp glsllexer.h
+ glslmemorypool.cpp glslmemorypool.h
+ glslparser.cpp glslparser.h
+ glslparsertable.cpp glslparsertable_p.h
+ glslsemantic.cpp glslsemantic.h
+ glslsymbol.cpp glslsymbol.h
+ glslsymbols.cpp glslsymbols.h
+ glsltype.cpp glsltype.h
+ glsltypes.cpp glsltypes.h
+)