aboutsummaryrefslogtreecommitdiffstats
path: root/src/libs/ssh/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/libs/ssh/CMakeLists.txt')
-rw-r--r--src/libs/ssh/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/src/libs/ssh/CMakeLists.txt b/src/libs/ssh/CMakeLists.txt
new file mode 100644
index 0000000000..6f5d1cb764
--- /dev/null
+++ b/src/libs/ssh/CMakeLists.txt
@@ -0,0 +1,22 @@
+add_qtc_library(QtcSsh
+ DEPENDS Qt5::Core Qt5::Network Qt5::Widgets Utils
+ SOURCES
+ sftpdefs.cpp sftpdefs.h
+ sftpfilesystemmodel.cpp sftpfilesystemmodel.h
+ sftpsession.cpp sftpsession.h
+ sftptransfer.cpp sftptransfer.h
+ ssh.qrc
+ ssh_global.h
+ sshconnection.cpp sshconnection.h
+ sshconnectionmanager.cpp sshconnectionmanager.h
+ sshkeycreationdialog.cpp sshkeycreationdialog.h sshkeycreationdialog.ui
+ sshlogging.cpp sshlogging_p.h
+ sshprocess.cpp sshprocess.h
+ sshconnection.cpp sshconnection.h
+ sshconnectionmanager.cpp sshconnectionmanager.h
+ sshkeycreationdialog.cpp sshkeycreationdialog.h sshkeycreationdialog.ui
+ sshlogging.cpp sshlogging_p.h
+ sshremoteprocess.cpp sshremoteprocess.h
+ sshremoteprocessrunner.cpp sshremoteprocessrunner.h
+ sshsettings.cpp sshsettings.h
+)