aboutsummaryrefslogtreecommitdiffstats
path: root/src/libs/utils/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/libs/utils/CMakeLists.txt')
-rw-r--r--src/libs/utils/CMakeLists.txt30
1 files changed, 13 insertions, 17 deletions
diff --git a/src/libs/utils/CMakeLists.txt b/src/libs/utils/CMakeLists.txt
index 4362294341..aa6a3e199e 100644
--- a/src/libs/utils/CMakeLists.txt
+++ b/src/libs/utils/CMakeLists.txt
@@ -1,8 +1,8 @@
add_qtc_library(Utils
- DEPENDS Qt::Qml Qt::Xml
+ DEPENDS Tasking Qt::Qml Qt::Xml
PUBLIC_DEPENDS
Qt::Concurrent Qt::Core Qt::Network Qt::Gui Qt::Widgets
- Qt6Core5Compat
+ Qt::Core5Compat
SOURCES
../3rdparty/span/span.hpp
../3rdparty/tl_expected/include/tl/expected.hpp
@@ -12,7 +12,7 @@ add_qtc_library(Utils
appmainwindow.cpp appmainwindow.h
archive.cpp archive.h
aspects.cpp aspects.h
- asynctask.cpp asynctask.h
+ async.cpp async.h
basetreeview.cpp basetreeview.h
benchmarker.cpp benchmarker.h
buildablehelperlibrary.cpp buildablehelperlibrary.h
@@ -45,6 +45,7 @@ add_qtc_library(Utils
execmenu.cpp execmenu.h
executeondestruction.h
expected.h
+ externalterminalprocessimpl.cpp externalterminalprocessimpl.h
fadingindicator.cpp fadingindicator.h
faketooltip.cpp faketooltip.h
fancylineedit.cpp fancylineedit.h
@@ -55,6 +56,8 @@ add_qtc_library(Utils
filepath.cpp filepath.h
filepathinfo.h
filesearch.cpp filesearch.h
+ filestreamer.cpp filestreamer.h
+ filestreamermanager.cpp filestreamermanager.h
filesystemmodel.cpp filesystemmodel.h
filesystemwatcher.cpp filesystemwatcher.h
fileutils.cpp fileutils.h
@@ -86,7 +89,6 @@ add_qtc_library(Utils
launcherpackets.cpp launcherpackets.h
launchersocket.cpp launchersocket.h
layoutbuilder.cpp layoutbuilder.h
- linecolumn.cpp linecolumn.h
link.cpp link.h
listmodel.h
listutils.h
@@ -124,6 +126,7 @@ add_qtc_library(Utils
port.cpp port.h
portlist.cpp portlist.h
predicates.h
+ process.cpp process.h
processenums.h
processhandle.cpp processhandle.h
processinfo.cpp processinfo.h
@@ -136,7 +139,6 @@ add_qtc_library(Utils
qrcparser.cpp qrcparser.h
qtcassert.cpp qtcassert.h
qtcolorbutton.cpp qtcolorbutton.h
- qtcprocess.cpp qtcprocess.h
qtcsettings.cpp qtcsettings.h
ranges.h
reloadpromptutils.cpp reloadpromptutils.h
@@ -144,6 +146,8 @@ add_qtc_library(Utils
runextensions.cpp runextensions.h
savefile.cpp savefile.h
scopedswap.h
+ scopedtimer.cpp scopedtimer.h
+ searchresultitem.cpp searchresultitem.h
set_algorithm.h
settingsaccessor.cpp settingsaccessor.h
settingsselector.cpp settingsselector.h
@@ -167,12 +171,12 @@ add_qtc_library(Utils
styleanimator.cpp styleanimator.h
styledbar.cpp styledbar.h
stylehelper.cpp stylehelper.h
- tasktree.cpp tasktree.h
templateengine.cpp templateengine.h
temporarydirectory.cpp temporarydirectory.h
temporaryfile.cpp temporaryfile.h
terminalcommand.cpp terminalcommand.h
- terminalprocess.cpp terminalprocess_p.h
+ terminalhooks.cpp terminalhooks.h
+ terminalinterface.cpp terminalinterface.h
textfieldcheckbox.cpp textfieldcheckbox.h
textfieldcombobox.cpp textfieldcombobox.h
textfileformat.cpp textfileformat.h
@@ -194,6 +198,7 @@ add_qtc_library(Utils
utils_global.h
utilstr.h
utilsicons.cpp utilsicons.h
+ utiltypes.h
variablechooser.cpp variablechooser.h
winutils.cpp winutils.h
wizard.cpp wizard.h
@@ -260,7 +265,7 @@ extend_qtc_library(Utils CONDITION UNIX AND NOT APPLE
extend_qtc_library(Utils
CONDITION TARGET Qt::CorePrivate
- DEPENDS Qt::CorePrivate
+ DEPENDS Qt::CorePrivate ptyqt
DEFINES QTC_UTILS_WITH_FSENGINE
SOURCES fsengine/fsengine_impl.cpp
fsengine/fsengine_impl.h
@@ -274,19 +279,10 @@ extend_qtc_library(Utils
)
if (WIN32)
- add_qtc_executable(qtcreator_process_stub
- SOURCES process_stub_win.c
- DEPENDS shell32
- DEFINES _UNICODE UNICODE _CRT_SECURE_NO_WARNINGS
- )
-
add_qtc_executable(qtcreator_ctrlc_stub
DEPENDS user32 shell32
DEFINES _UNICODE UNICODE _CRT_SECURE_NO_WARNINGS
SOURCES
process_ctrlc_stub.cpp
)
-else()
- add_qtc_executable(qtcreator_process_stub SOURCES process_stub_unix.c)
endif()
-